Can't reach official Nextcloud website (is my IP banned?)

The problem I face is a really strange one (and is not directly related to my Nextcloud instance).

I am not able to reach the official website (nor ping it). I keep getting timeouts. I get this from my nextcloud server, but also when I connect using regular webbrowsers (firefox etc.) an regular desktop computers. I simply get no site presented. It “feels” like my IP got banned for some reason (as if my http-requests get dropped?)?

The strange thing is: it suddenly surfaced. Yesterday I had no problems, nothing changed locally on my firewall or anything. It does seem tied to my network (I tried pinging from my router and that resulted in a timeout), but from other networks there is no problem.

The ONLY correlation I see is that I was working on the upgrade of my Nextcloud server. Have I accidentally spammed your web-server that resulted an an IP ban or anything?


  • I upgraded my Nextcloud instance to version 14.0.1
  • Got some new warnings that I addressed (redis caching, sendmail implementation, etc). NB: I addressed them incrementally, so I may have run with an incompletely configured instance of Nextcloud.
  • Suddenly is down when I try to browse to it and/or ping it from my network.

Another weird thing is that I can normally reach the nextcloud subdomains… :confused: So and all seem fine, but is not (timeout)…

Any idea’s? It would be immensely appreciated!

Update: I do get a lot of the following in my logs, but I think this is another result of the matter not the cause:

GuzzleHttp\Exception\ConnectException: cURL error 7: Failed to connect to port 80: Connection timed out (see

Hmm it’s been 24h. Maybe an official can tell me whether or not Nextcloud bans IP’s to begin with or not?

If it this can be caused by a webserver-side ban of my IP than please contact me!

Any other information and/or idea’s are welcome too (I’ve totally ran out of things to check)…

Maybe your ISP’s TTL expired and the route is lost? Check from any other device not connecting through the router/ISP you are seeing the error from?

Thanks for thinking along!!

Hmm, interesting thought… Are you referring to DNS TTL? (if so I can not connect nor ping the official site using either).

I did check with other devices/connections (4G phone / from my work’s network) and then it does work, so it indeed is related to my router (probably not), my ISP (or other central mediating system), or that did something specific to me (it is up for others/from other networks).

I am so stumped…

TLDR; The issue is gone but I do not know how/why it happened, nor how it got solved.

Well… Out of frustration I put my nextcloud-server in offline mode via the config setting (as various services that apparently required connection were “spamming” my logs):

‘has_internet_connection’ =>; false,

Then all of a sudden about 12h later (guestimate), i was able to ping and connect to again.

Not sure whether my change (implicitly) fixed the issue (as a mediator or mediator) or that it was my ISP that changed things (I’m thinking caches, firewalls, (reverse)DNS, related stuff), or that lifted “the ban” of my IP-address, a combination of the three or something completely different…

Ah well… let’s just hope it was a one-time incident (thanks to those that thought along)!