Can't open documents with Collabora

Steps to reproduce

  1. Initialize the server and restore it.
    2.Collabora Container installation.
    3.Open Spreadsheet or Document file

Expected behaviour

The document opens

Actual behaviour

When I try to open a spreadsheet or document with Collabora, a progress icon is displayed for a moment, it disappears and processing stops. The screen is an upper and lower tool bar (operable), and the middle is gray. The essential document is not displayed. There is no error display in the log.
The settings of nginx, php-fpm, php.ini, my.cnf are the same as before. I tried installing and uninstalling Collabora several times, but the situation does not change at all.
If I invalidate the sub/second domain for Collabora, a dialog of WOPI error will be displayed.

General server configuration

Operating system: Linux MY-HOSTNAME 3.10.0-514.2.2.el7.centos.plus.x86_64 #1 SMP Wed Dec 7 19:10:15 UTC 2016 x86_64

Web server: nginx/1.11.10 (fpm-fcgi)

Database: mysql 5.5.56

PHP version: 7.1.10

PHP-modules loaded
 - Core
 - date
 - libxml
 - openssl
 - pcre
 - zlib
 - bz2
 - calendar
 - ctype
 - hash
 - filter
 - ftp
 - gettext
 - gmp
 - SPL
 - iconv
 - Reflection
 - session
 - standard
 - SimpleXML
 - sockets
 - mbstring
 - tokenizer
 - xml
 - cgi-fcgi
 - mysqlnd
 - bcmath
 - curl
 - dba
 - dom
 - enchant
 - fileinfo
 - gd
 - imagick
 - imap
 - intl
 - json
 - ldap
 - exif
 - mcrypt
 - mysqli
 - odbc
 - PDO
 - pdo_mysql
 - PDO_ODBC
 - pdo_pgsql
 - pdo_sqlite
 - pgsql
 - Phar
 - posix
 - pspell
 - redis
 - soap
 - sqlite3
 - sysvmsg
 - sysvsem
 - sysvshm
 - tidy
 - xmlreader
 - xmlrpc
 - xmlwriter
 - xsl
 - zip
 - Zend OPcache
 - apcu

Nextcloud configuration

Nextcloud version: 12.0.3 - 12.0.3.3

Updated from an older Nextcloud/ownCloud or fresh install: NC 12.0.0

Where did you install Nextcloud from: nextcloud.com

Are you using external storage, if yes which one: Array
(
[0] => \OC\Files\Storage\Local
[2] => \OC\Files\Storage\DAV
[4] => \OCA\Files_External\Lib\Storage\SFTP
)

Are you using encryption: no

Are you using an external user-backend, if yes which one: Webdav

Signing status
[]
Enabled apps
 - activity: 2.5.2
 - admin_audit: 1.2.0
 - apporder: 0.4.0
 - bruteforcesettings: 1.0.2
 - calendar: 1.5.5
 - comments: 1.2.0
 - contacts: 2.0.1
 - dav: 1.3.0
 - encryption: 1.6.0
 - federatedfilesharing: 1.2.0
 - federation: 1.2.0
 - files: 1.7.2
 - files_automatedtagging: 1.2.2
 - files_clipboard: 0.6.4
 - files_external: 1.3.0
 - files_markdown: 2.0.1
 - files_pdfviewer: 1.1.1
 - files_sharing: 1.4.0
 - files_texteditor: 2.4.1
 - files_trashbin: 1.2.0
 - files_versions: 1.5.0
 - files_videoplayer: 1.1.0
 - gallery: 17.0.0
 - issuetemplate: 0.2.2
 - logreader: 2.0.0
 - lookup_server_connector: 1.0.0
 - mail: 0.7.3
 - nextcloud_announcements: 1.1
 - notes: 2.3.1
 - notifications: 2.0.0
 - oauth2: 1.0.5
 - password_policy: 1.2.2
 - provisioning_api: 1.2.0
 - ransomware_protection: 1.0.4
 - richdocuments: 1.12.35
 - serverinfo: 1.2.0
 - sharebymail: 1.2.0
 - survey_client: 1.0.0
 - systemtags: 1.2.0
 - tasks: 0.9.5
 - theming: 1.3.0
 - twofactor_backupcodes: 1.1.1
 - updatenotification: 1.2.0
 - workflowengine: 1.2.0
Disabled apps
Content of config/config.php
{
    "instanceid": "oc91acrupdf0",
    "passwordsalt": "***REMOVED SENSITIVE VALUE***",
    "secret": "***REMOVED SENSITIVE VALUE***",
    "trusted_domains": [
        "MY-DOMAIN"
    ],
    "datadirectory": "\/MYNEXTCLOUD\/data",
    "overwrite.cli.url": "https:\/\/MYNEXTCLOUDDOMAIN",
    "dbtype": "mysql",
    "version": "12.0.3.3",
    "dbname": "MYDB",
    "dbhost": "localhost:3306",
    "dbport": "",
    "dbtableprefix": "oc_",
    "mysql.utf8mb4": true,
    "dbuser": "***REMOVED SENSITIVE VALUE***",
    "dbpassword": "***REMOVED SENSITIVE VALUE***",
    "installed": true,
    "log_type": "owncloud",
    "logfile": "nextcloud.log",
    "loglevel": 3,
    "memcache.local": "\\OC\\Memcache\\APCu",
    "filelocking.enabled": true,
    "memcache.locking": "\\OC\\Memcache\\Redis",
    "redis": {
        "host": "localhost",
        "port": 6379,
        "password": "***REMOVED SENSITIVE VALUE***"
    },
    "mail_smtpmode": "smtp",
    "mail_smtpauthtype": "LOGIN",
    "mail_smtpsecure": "ssl",
    "mail_from_address": "drive",
    "mail_domain": "MAIL.DOMAIN",
    "mail_smtpauth": 1,
    "mail_smtphost": "SMTP.DOMAIN",
    "mail_smtpport": "465",
    "mail_smtpname": "***REMOVED SENSITIVE VALUE***",
    "mail_smtppassword": "***REMOVED SENSITIVE VALUE***",
    "maintenance": false,
    "auth.bruteforce.protection.enabled": false,
    "versions_retention_obligation": "7,auto",
    "trashbin_retention_obligation": "auto",
    "enabledPreviewProviders": [
        "OC\\Preview\\PNG",
        "OC\\Preview\\JPEG",
        "OC\\Preview\\GIF",
        "OC\\Preview\\BMP",
        "OC\\Preview\\XBitmap",
        "OC\\Preview\\MP3",
        "OC\\Preview\\TXT",
        "OC\\Preview\\MarkDown"
    ],
    "defaultapp": "mail"
}

Client configuration

Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Operating system: Windows10, macOS Sierra, iOS11

Logs

Web server error log
Insert your webserver log here
Nextcloud log (data/nextcloud.log)
Insert your Nextcloud log here
Browser log
Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log
c) ...

Hi,

Did you use encryption before the problem occurred the first time? Collabora doesn’t work with Encryption enabled on Nextcloud:

Issue: Collabora Online doesn’t work with Encryption.
Yes, this is currently unsupported.

(https://nextcloud.com/collaboraonline/ right at the bottom the last troubleshooting tipp)

If the documents are anyhow placed outside encrypted folders (so are not encrypted):
Can you please try the following

  • set the log level for nextcloud to debug
  • reproduce the problem (open a document)
  • check again and probably post the nextcloud log
  • check the Collabora logs for error messages
  • check system logs for error messages

I use Encrypt the home storage only.
I initialized the server and restored it. Previously it was possible to use the same encryption. Basically the configuration file was restored from the backup file. Nonetheless, MySQL (my.cnf) also had problems with innoDB becoming unusable. Something is slightly different so I may not be reproducing the same environment. However, it was completely the same setup regarding the installation of Collabora.

I see Collabora’s error, nextcloud logs, no errors are displayed.

Collabora Online does work with Encryption. The info on https://nextcloud.com/collaboraonline/ is outdated.

Even though denied, I was working realistically. In other words, I guess encryption was not working due to bugs.

I can not open documents even if I disable encryption(encrypt the home storage) now.

Excuse me. I made a mistake in reading.
In the latest information, it means that there is no problem even if encrypted.

Where are the elements that seem to be affected by others?
I tried disable the application of Nextcloud as much as possible, but the state did not change.

When I stop the Collabora online server, I get a WOPI host error like the image below.

When I restart the Collabora online server, the WOPI error dialog of the above image is not displayed.

I made HTTP/2 correspondence, but this had no effect.

I solved the MySQL error problem afterwards and I was able to rebuild it just like the old environment. But I still can’t open the Collabora files. And I also made a new nginx configuration file. Still no change. I replaced the source of Nextcloud itself with a newly downloaded one as a precaution.

After all, some setting is incorrect. What on earth is the cause?

I have not been able to solve it yet. I am desperately looking for a solution.
Before the server restoration it could be used. What exactly happens to the server?

I attempted to access Collabora Online dedicated server(https://office.mynextcloud.com:9980) directly with a web browser.
In the case of Firefox, “It is not a secure connection.”, “This site uses HTTP Strict Transport Security (HSTS) which specifies Firefox to connect only with encrypted communication, so we can not add this certificate as an exception.” For the above reasons Firefox can not proceed.

In the case of Vivaldi, "Privacy is not protected on this connection."
Unlike Firefox, I can proceed to the site by clicking on details. But it is a blank screen. Only “OK” letters in the upper left.

What I care about here is that HSTS is used on Collabora’s site. I am operating a multi domain on one server. It is two (for example) www.mynextcloud.com and office.mynextcloud.com. According to the specification of HSTS, if using HSTS on one side will HSTS work on the other side too? I can not solve it unless I check it from such a trivial point.

I also saw some errors in /var/log/. No fatal error occurred in any of them. There were (warning) error such that ???.so(msql, apcu, pdo_msql …) was called more than once or pm.max_children approached its upper limit. These resolved.

When I see the behavior of Collabora, processing is over with “initializing” at Collabora. Collabora seems to be unable to connect to the file.

Please tell me which server setting should doubt.

*After that, I reset the server again and rebuild it in a state quite close to the initial state. I have not updated each server component.
I also tried the old version of Collabora Docker. When Ver.2.1.2 or 2.1.3 Collabora’s toolbar is not displayed.

I got a comment from several people. Thank you to them. I was able to solve it self.
I do not know the cause is clear. I checked all the syntax and set it again. That’s it.