Can't mount external storage


I set up external storage.
The external storage is used for workgroup authentication.
I set it as follows.

・hosts : IPAddres
・share : share folder name
・remote sub folder :
・domain : WORKGROUP or
・user : user name
・password : password

The username and password are correct.
However, the lamp is a red square.

Nextcloud setup as follows

Nextcloud : 14.0.3
OS : CentOS 7.4.1708
DB : MariaDB 5.5.56
Nginx : 1.15.6
PHP : 7.2.12

What should I do to connect to workgroup certified storage with Nextcloud?


Have no samba configured, but try to added //IPAddres instead IPAddres. Also I believe you have to specify remote sub folder.
This is doc related to samba:

have you tried to get on using this useful app, already? it’s free and easy to install from the nc-appstore

smb connection test

1 Like

Hi gas85
I entered //IPaddress instead of IPaddress.
I also enterd specify sub folder name in a remote sub folder.
however,the lamp is red square.

Hi JimmyKater,

I used smb_test, but the message “Icewind \ SMB \ Exception \ ConnectionRefusedException: /IPaddess/share folder name” was displayed.

I entered the following.
Hostname : //IPaddress
User : user name
Workgroup : WORKGROUP
Password : password
Share : Share folder name

I tried smb_test as folows.
Hostname : IPaddress
User :
Workgroup :
Password :
Share :

Then the shared folder list was displayed.

However, if you enter your username and password, you will see the following message: Icewind\SMB\Exception\ForbiddenException: Invalid request for (ForbiddenException)

I also found that I can access NAS operated by Active Directory.

However, in the case of WORKGROUP certification, it is not yet known how NAS connection is possible.

Hi @sw-BEC,

have you solved this? I have the same issue accesing a Windows 2016 Share, but users are able to browse the share via web and not via sync client.

Hi serverhack
I haven’t solved this problem yet.

We can’t share because we don’t have samba on our OS.

But it’s strange, users can see the shares on the NC web interface, but that shares aren’t displayed in the sync directories list of the desktop app.

If I test the Windows Server shared against SMB Connection Test I received a "Icewind\SMB\Exception\ConnectionRefusedException using php-smbclient as backend.

I also get the same error.

I also get the same error.

Hi, I’ve been able to mount it saving the login credentials to database instead of session when you define the external SMB.

Hey, i just entered my “WORKGROUP” workgroup into the domain field and it worked !
To mee the empty Domain Field was the problem.


SAME, i set “domain” to local and it resolved on all existing shares; (stupid)

Guys, can pls some of you publish a printscreen of how to set up external storage using AD account. I simply can’t get this running, despite authentication goes through and can be seen as successful in EventViewer on server side. However nextcloud doesn’t want to save an external storage for unknown reason.

Thanks :slight_smile: