Can't login to webapp (all users), sync app IS logged in

Updated to 20.0.1 can’t log into webapp. Rather troubleshoot than restore backup.

Regular users and admin cannot log in. On login attempt the screen refreshes, not errors in browser

Sync app is logged in.

Reset password for admin via occ. No joy.

Checked code with occ no issues

There were some php modules updated today.

PHP 7.3
centos 8

UPDATE: disregard the sync app is logged in.

Check the web server and Nextcloud log file for any related error message. If php modules have been updated today, one required module is most likely missing which prevents a successful login. You will find many similar reports using the search function of this forum.

Did you try this from @Utopiah ?

Nothing in nextcloud logs

In nginx logs this is repeated every 30 seconds:

2020/10/27 16:55:53 [error] 1868#0: *2082 connect() failed (111: Connection refused) while connecting to upstream, client: 192.168.1.132, server: cloud.sld.tld request: “GET /ocs/v1.php/cloud/user?format=json HTTP/1.1”, upstream: “fastcgi://127.0.0.1:9000”, host: “cloud.steiner.house”

I was thinking it might be some brute force protection, but I tried logging in from another device and that didn’t work.

The IP listed is my workstation, Fedora. The attempts were from the sync app but the app showed logged in. I logged out and the errors stopped.

Still no log in from browser. I also updated a few apps.

Doesn’t seem to pertain to me. I can’t log in from workstation or anywhere. It’s not accepting passwords for any account. I change the passwords using occ but no joy.

same here.

OS: Centos 8 (latest version)

Webserver: Nginx

Nextcloud:

  • installed: true
  • version: 17.0.2.1
  • versionstring: 17.0.2
  • edition:

I can login and sync data via “filesync pro” on andoid however I cannot login with any user throu the webinterface – passwordreset does not help. no browser works on different maschines.

I also noticed today some PHP updates:

The following updates have been applied on ‘myServer.tld’:

Package Arch Version Repository Size

Upgrading:
php-cli x86_64 7.3.24-1.el8.remi remi-modular 4.6 M
php-common x86_64 7.3.24-1.el8.remi remi-modular 1.1 M
php-devel x86_64 7.3.24-1.el8.remi remi-modular 1.2 M
php-fpm x86_64 7.3.24-1.el8.remi remi-modular 1.6 M
php-gd x86_64 7.3.24-1.el8.remi remi-modular 90 k
php-intl x86_64 7.3.24-1.el8.remi remi-modular 242 k
php-json x86_64 7.3.24-1.el8.remi remi-modular 74 k
php-mbstring x86_64 7.3.24-1.el8.remi remi-modular 523 k
php-mysqlnd x86_64 7.3.24-1.el8.remi remi-modular 254 k
php-opcache x86_64 7.3.24-1.el8.remi remi-modular 324 k
php-pdo x86_64 7.3.24-1.el8.remi remi-modular 140 k
php-process x86_64 7.3.24-1.el8.remi remi-modular 95 k
php-xml x86_64 7.3.24-1.el8.remi remi-modular 231 k

Transaction Summary

Upgrade 13 Packages

Please help

Due to the fact that the “connection refused” message is logged to the nginx log file, the root cause of the problem is most likely located in your nginx configuration, otherwise such a message would be logged to the Nextcloud log file.

Aunt G. provides several hints how to narrow down such kind of problems:

I created new nextcloud install on the same server with a new serverblock copied from nextcloud docs. Same problem, can’t make initial log in after install

for what it’s worth, the nextcloud log time stamp is in UTC while my server is in another timezone.

nextcloud.log error:

{“reqId”:“asdf”,“level”:3,“time”:“2020-10-28T16:10:38+00:00”,“remoteAddr”:“192.168.1.132”,“user”:"–",“app”:“index”,“method”:“GET”,“url”:"/apps/theming/icon?v=0",“message”:{“Exception”:“OCP\Files\NotPermittedException”,“Message”:“Could not create folder”,“Code”:0,“Trace”:[{“file”:"/var/www/domains/asdf/public_html/lib/private/Files/AppData/AppData.php",“line”:157,“function”:“newFolder”,“class”:“OC\Files\Node\Folder”,“type”:"->",“args”:[“0”]},{“file”:"/var/www/domainsasdf/public_html/apps/theming/lib/ImageManager.php",“line”:155,“function”:“newFolder”,“class”:“OC\Files\AppData\AppData”,“type”:"->",“args”:[“0”]},{“file”:"/var/www/domains/asdf/public_html/apps/theming/lib/ImageManager.php",“line”:170,“function”:“getCacheFolder”,“class”:“OCA\Theming\ImageManager”,“type”:"->",“args”:[]},{“file”:"/var/www/domains/asdf/public_html/apps/theming/lib/Controller/IconController.php",“line”:164,“function”:“getCachedImage”,“class”:“OCA\Theming\ImageManager”,“type”:"->",“args”:[“touchIcon-core”]},{“file”:"/var/www/domains/asdf/public_html/lib/private/AppFramework/Http/Dispatcher.php",“line”:169,“function”:“getTouchIcon”,“class”:“OCA\Theming\Controller\IconController”,“type”:"->",“args”:[“core”]},{“file”:"/var/www/domains/asdf/public_html/lib/private/AppFramework/Http/Dispatcher.php",“line”:100,“function”:“executeController”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:"->",“args”:[{“class”:“OCA\Theming\Controller\IconController”},“getTouchIcon”]},{“file”:"/var/www/domains/asdf/public_html/lib/private/AppFramework/App.php",“line”:152,“function”:“dispatch”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:"->",“args”:[{“class”:“OCA\Theming\Controller\IconController”},“getTouchIcon”]},{“file”:"/var/www/domains/asdf/public_html/lib/private/Route/Router.php",“line”:308,“function”:“main”,“class”:“OC\AppFramework\App”,“type”:"::",“args”:[“OCA\Theming\Controller\IconController”,“getTouchIcon”,{“class”:“OC\AppFramework\DependencyInjection\DIContainer”},{“app”:“core”,“action”:null,"_route":“theming.Icon.getTouchIcon”}]},{“file”:"/var/www/domains/asdf/public_html/lib/base.php",“line”:1009,“function”:“match”,“class”:“OC\Route\Router”,“type”:"->",“args”:["/apps/theming/icon"]},{“file”:"/var/www/domains/asdf/public_html/index.php",“line”:37,“function”:“handleRequest”,“class”:“OC”,“type”:"::",“args”:[]}],“File”:"/var/www/domains/asdf/public_html/lib/private/Files/Node/Folder.php",“Line”:167,“CustomMessage”:"–"},“userAgent”:“Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:81.0) Gecko/20100101 Firefox/81.0”,“version”:“20.0.1.1”}

New installation means new problems. I would have tried to fix the nginx configuration instead opening a new construction site. :wink:

You should read the Nextcloud administrator guide to better understand how Nextcloud works, and focus on the “logtimezone” parameter.

You should check the folder/files ownership and access rights of your Nextcloud installation. This information can usually also be found in the Nextcloud administrator guide.

In my nginx logs there are no errors during login attent:

78.34.241.188 - - [29/Oct/2020:09:14:08 +0100] “POST /login HTTP/2.0” 303 0 “-” “Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:81.0) Gecko/20100101 Firefox/81.0” “-”
78.34.241.188 - - [29/Oct/2020:09:14:09 +0100] “GET /apps/files/ HTTP/2.0” 303 0 “-” “Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:81.0) Gecko/20100101 Firefox/81.0” “-”
78.34.241.188 - - [29/Oct/2020:09:14:09 +0100] “GET /login?redirect_url=/apps/files/ HTTP/2.0” 200 3508 “-” “Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:81.0) Gecko/20100101 Firefox/81.0” “-”
78.34.241.188 - - [29/Oct/2020:09:14:09 +0100] “GET /cron.php HTTP/2.0” 200 40 “-” “Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:81.0) Gecko/20100101 Firefox/81.0” “-”

However The Webpage just ignores my attemt and asks me again to login. Where to search for the actual posted error?

I used that Howto.

Note: If there would have been a misconfiguration the setup yould have been never worked, but it did until Auto Package updates I guess as there was not other touch the that machine

FYI, I rolled back that update and no joy.

Can anybody please lead us to a better debugging what is going on, why the login via webinterface is not working anoymore ?

I noticed in my nginx access log I have connection every 30 seconds from my workstation even though I removed the account from my sync client

192.168.1.132 - - [30/Oct/2020:11:26:58 -0500] “POST /login/v2/poll HTTP/1.1” 404 2 “-” “Mozilla/5.0 (Linux) mirall/2.6.5git (Nextcloud)” “-”
192.168.1.132 - - [30/Oct/2020:11:27:28 -0500] “POST /login/v2/poll HTTP/1.1” 404 2 “-” “Mozilla/5.0 (Linux) mirall/2.6.5git (Nextcloud)” “-”

hmmm, looks like it was a very bad choice to give a try to nextcloud, I think I will go back to owncloud. As it is simply not acceptable that this software hold such important data and is for unknown reasons on the next day not usable anymore, without touching the server at all.
In addition it is kind of poor that He do not get hier propper responce of how to isolate the bug – CYE!

I ended up putting it on its own apache server.

I was sharing the previous server with a few other things, tomcat, docker, … And determined it was best to give nextcloud its own virtual machine, since for me, it’s a single point of failure in my workflow.

I had the n/c installation on a non-virtual dedicated server. The VM is cool because it’s easy to take snapshots of the OS. I keep the OS and data directories on separate virtual disks. This allows me to peridocially take OS snapshots without the extra overhead of data. Plus the machine can be exported to other hosts.

Data and the nextcloud database itself are cloned independantly.

I’ve used OC and NC for 7 or so years. I’ve had problems pop up inm both. I think the configuration above will limit downtime. Most problems that popup seem to be related to updates. So I take my time updating the installation and apps.