Can't login in Nextcloud 24

Nextcloud version: 24.0.0
Operating system and version: Ubuntu 18.04
Apache or nginx version: Apache 2.4.29
PHP version: 8.0.18

The issue you are facing:
I think that updating to Nextcloud 24.0.0 broke my installation. Today I reached my installation and I can’t login. Checked username and password but it didn’t accept them, it just reloads the page.

I tried reset the password but it said that it was impossible and that I should reach he admnistrator (me).

I tried downgrading php from 8.1 to 8.0, I also removed php8.1 and restarted the apache server.

I know I should have some backups because I enabled them, but I don’t know where they are stored.

Is this the first time you’ve seen this error?:

Yes. When I update Nextcloud it always has problems, but this time I can’t find which one.

Steps to replicate it:

  1. Update Nextcloud
  2. At next access, get prompted to login

The output of your Nextcloud log in Admin > Logging:
I can’t access it since I can’t enter in Nextcloud.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'ocpw2e29q8ij',
  'passwordsalt' => 'XXXX',
  'secret' => 'XXXX',
  'trusted_domains' => 
  array (
    0 => '',
    1 => '',
  'datadirectory' => '/var/www/',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => 'XXXX',
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'filelocking.enabled' => true,
  'redis' => 
  array (
    'host' => '/var/run/redis/redis-server.sock',
    'port' => 0,
    'dbindex' => 0,
    'password' => 'XXX',
    'timeout' => 1.5,
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 0,
  'app_install_overwrite' => 
  array (
    0 => 'passman',
    1 => 'breezedark',
    2 => 'nextbackup',
  'htaccess.RewriteBase' => '/',
  '' => 'stable',
  'default_phone_region' => 'IT',
  'mail_from_address' => 'samuele.zappala',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => '',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => '',
  'mail_smtpname' => '',
  'mail_smtppassword' => 'XXXXX',
  'ldapProviderFactory' => 'OCA\\User_LDAP\\LDAPProviderFactory',
  'updater.secret' => '$2y$10$wHom.jAAq4NJrjXT9unbK.AqnhFbfcfG2n49Rq1.O6LAMgaloEWzG',

The output of your Apache/nginx/system log in /var/log/____:

[Thu May 05 10:16:25.669829 2022] [mpm_prefork:notice] [pid 1305] AH00169: caught SIGTERM, shutting down
[Thu May 05 10:16:25.857002 2022] [mpm_prefork:notice] [pid 3390] AH00163: Apache/2.4.29 (Ubuntu) OpenSSL/1.1.1 configured -- resuming normal operations
[Thu May 05 10:16:25.857076 2022] [core:notice] [pid 3390] AH00094: Command line: '/usr/sbin/apache2'

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

I checked the nextcloud.log but the last entry is about two hours ago.

Just intervened in a Nextcloud News issue with php ./occ news:updater:before-update, I don’t know if it is related but now I can login…

I’ll try upgrading again to php8.1 and see what happens.

I have to say that sometimes it just doesn’t login at the first try, but it usually logs in at the second try. This time I tried like twenty times minutes apart.

You might run into trouble installing Php 8.1
It is still finalizing testing in last beta.