Can't login after migration to new server

Hi there,

I’ve migrated nextcloud to new server. I’ve moved nextcloud folder with scp and installed mysql apache and php, dumped and imported the database. At the moment I can see login page but It doesn’t let me in. My shell history on new server in below.

https://pastebin.pl/view/86f884c5

Can you post data/nextcloud.log ?

tail -f /var/www/html/nextcloud/data/nextcloud.log
{"reqId":"XzJAIikCx7zRZFhnxg7rOQAAAAE","level":3,"time":"2020-08-11T06:52:18+00:00","remoteAddr":"192.168.5.142","user":"--","app":"PHP","method":"GET","url":"/index.php/apps/theming/img/core/filetypes/text.svg?v=23","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/nextcloud/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36 OPR/69.0.3686.77","version":"18.0.4.2"}
{"reqId":"XzJAItSgBNRMpPnOObqgNwAAAAc","level":3,"time":"2020-08-11T06:52:18+00:00","remoteAddr":"192.168.5.142","user":"--","app":"PHP","method":"GET","url":"/index.php/apps/theming/img/core/filetypes/folder.svg?v=23","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/nextcloud/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36 OPR/69.0.3686.77","version":"18.0.4.2"}
{"reqId":"XzJAIikCx7zRZFhnxg7rOgAAAAE","level":3,"time":"2020-08-11T06:52:18+00:00","remoteAddr":"192.168.5.142","user":"--","app":"PHP","method":"GET","url":"/index.php/apps/theming/img/core/filetypes/folder-drag-accept.svg?v=23","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/nextcloud/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36 OPR/69.0.3686.77","version":"18.0.4.2"}
{"reqId":"XzJAIwsQWOZaQTzANPlSnwAAAAM","level":3,"time":"2020-08-11T06:52:19+00:00","remoteAddr":"192.168.5.142","user":"--","app":"PHP","method":"GET","url":"/cron.php","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/nextcloud/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36 OPR/69.0.3686.77","version":"18.0.4.2"}
{"reqId":"XzJAjDHg59Xf38YBHB4KygAAAAA","level":3,"time":"2020-08-11T06:54:04+00:00","remoteAddr":"192.168.5.142","user":"--","app":"PHP","method":"POST","url":"/index.php/login","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/nextcloud/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36 OPR/69.0.3686.77","version":"18.0.4.2"}
{"reqId":"XzJAjDHg59Xf38YBHB4KywAAAAA","level":3,"time":"2020-08-11T06:54:04+00:00","remoteAddr":"192.168.5.142","user":"--","app":"PHP","method":"GET","url":"/index.php/apps/files/","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/nextcloud/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36 OPR/69.0.3686.77","version":"18.0.4.2"}
{"reqId":"XzJAjDHg59Xf38YBHB4KzAAAAAA","level":3,"time":"2020-08-11T06:54:04+00:00","remoteAddr":"192.168.5.142","user":"--","app":"PHP","method":"GET","url":"/index.php/login?redirect_url=/index.php/apps/files/","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/nextcloud/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36 OPR/69.0.3686.77","version":"18.0.4.2"}
{"reqId":"XzJAjTHg59Xf38YBHB4KzQAAAAA","level":3,"time":"2020-08-11T06:54:05+00:00","remoteAddr":"192.168.5.142","user":"--","app":"PHP","method":"GET","url":"/cron.php","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/nextcloud/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36 OPR/69.0.3686.77","version":"18.0.4.2"}
{"reqId":"XzJAjSkCx7zRZFhnxg7rPAAAAAE","level":3,"time":"2020-08-11T06:54:05+00:00","remoteAddr":"192.168.5.142","user":"--","app":"PHP","method":"GET","url":"/index.php/login?redirect_url=/index.php/apps/files/","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/nextcloud/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36 OPR/69.0.3686.77","version":"18.0.4.2"}
{"reqId":"XzJDXedbdq22vZRP1I8y3AAAAAQ","level":3,"time":"2020-08-11T07:06:06+00:00","remoteAddr":"192.168.5.142","user":"--","app":"PHP","method":"GET","url":"/index.php/csrftoken","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/nextcloud/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36 OPR/69.0.3686.77","version":"18.0.4.2"}

Install the package “php-intl” and repeat your log output.

Look for further packages (sorry Debian).

https://www.howtoforge.com/tutorial/how-to-install-nextcloud-on-debian-10

I’ve followed this tutorial, nothing changed after installing php-intl. https://computingforgeeks.com/install-nextcloud-on-centos-with-php-apache-mariadb/

{"reqId":"XzJDXedbdq22vZRP1I8y3AAAAAQ","level":3,"time":"2020-08-11T07:06:06+00:00","remoteAddr":"192.168.5.142","user":"--","app":"PHP","method":"GET","url":"/index.php/csrftoken","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/nextcloud/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36 OPR/69.0.3686.77","version":"18.0.4.2"}

Read and execute.

I don’t have Cpanel, It seems like enabled.

yum list installed | grep php
oniguruma5php.x86_64             6.9.5+rev1-2.el7.remi            @remi-safe
php.x86_64                       7.3.21-1.el7.remi                @remi-php73
php-bcmath.x86_64                7.3.21-1.el7.remi                @remi-php73
php-cli.x86_64                   7.3.21-1.el7.remi                @remi-php73
php-common.x86_64                7.3.21-1.el7.remi                @remi-php73
php-devel.x86_64                 7.3.21-1.el7.remi                @remi-php73
php-fedora-autoloader.noarch     1.0.1-2.el7                      @epel
php-gd.x86_64                    7.3.21-1.el7.remi                @remi-php73
php-intl.x86_64                  7.3.21-1.el7.remi                @remi-php73
php-json.x86_64                  7.3.21-1.el7.remi                @remi-php73
php-mbstring.x86_64              7.3.21-1.el7.remi                @remi-php73
php-mysqlnd.x86_64               7.3.21-1.el7.remi                @remi-php73
php-pdo.x86_64                   7.3.21-1.el7.remi                @remi-php73
php-pear.noarch                  1:1.10.12-1.el7.remi             @remi-php73
php-pecl-apcu.x86_64             5.1.18-1.el7.remi.7.3            @remi-php73
php-pecl-apcu-devel.x86_64       5.1.18-1.el7.remi.7.3            @remi-php73
php-pecl-mcrypt.x86_64           1.0.3-1.el7.remi.7.3             @remi-php73
php-pecl-zip.x86_64              1.19.0-1.el7.remi.7.3            @remi-php73
php-process.x86_64               7.3.21-1.el7.remi                @remi-php73
php-xml.x86_64                   7.3.21-1.el7.remi                @remi-php73

Please execute. If Ubuntu with “sudo” if not Ubuntu then as root without sudo.

phpenmod intl
systemctl restart apache2

If nginx restart ngix or boot your server.
Post error or messages at “phpenmod intl”.

I’ve realized logging is stopped. I’m not able to see lastest requests in nexcloud.log file. Permissions and owner is line below
-rw-r-----. 1 apache apache 4310033 Aug 11 10:06 nextcloud.log

# phpenmod intl
-bash: phpenmod: command not found
# php -m
[PHP Modules]
apcu
bcmath
bz2
calendar
Core
ctype
curl
date
dom
exif
fileinfo
filter
ftp
gd
gettext
hash
iconv
intl
json
libxml
mbstring
mcrypt
mysqli
mysqlnd
openssl
pcntl
pcre
PDO
pdo_mysql
pdo_sqlite
Phar
posix
readline
Reflection
session
shmop
SimpleXML
sockets
SPL
sqlite3
standard
sysvmsg
sysvsem
sysvshm
tokenizer
wddx
xml
xmlreader
xmlwriter
xsl
zip
zlib

[Zend Modules]

# zts-php -m
[PHP Modules]
apcu
bcmath
bz2
calendar
Core
ctype
curl
date
dom
exif
fileinfo
filter
ftp
gd
gettext
hash
iconv
intl
json
libxml
mbstring
mcrypt
mysqli
mysqlnd
openssl
pcntl
pcre
PDO
pdo_mysql
pdo_sqlite
Phar
posix
readline
Reflection
session
shmop
SimpleXML
sockets
SPL
sqlite3
standard
sysvmsg
sysvsem
sysvshm
tokenizer
wddx
xml
xmlreader
xmlwriter
xsl
zip
zlib

[Zend Modules]

I’ve resolved this issue via uninstall php 7.3 and install php 7.2 from original server command history.

yum autoremove php-*
sudo yum-config-manager --enable remi-php72
sudo yum-config-manager --disable remi-php73
yum install -y rh-php72 rh-php72-php rh-php72-php-gd rh-php72-php-mbstring rh-php72-php-intl rh-php72-php-pecl-apcu rh-php72-php-mysqlnd rh-php72-php-pecl-redis rh-php72-php-opcache rh-php72-php-imagick rh-php72-php-ldap
ln -s /opt/rh/httpd24/root/etc/httpd/conf.d/rh-php72-php.conf /etc/httpd/conf.d/
ln -s /opt/rh/httpd24/root/etc/httpd/conf.modules.d/15-rh-php72-php.conf/etc/httpd/conf.modules.d/
ln -s /opt/rh/httpd24/root/etc/httpd/modules/librh-php72-php7.so /etc/httpd/modules/
ln -s /opt/rh/rh-php72/root/bin/php /usr/bin/php
systemctl restart httpd