Can't import bookmarks, unsupported file type

I’m using a free account on us.hostiso.cloud. When I try to import bookmarks, it just says, “Unsupported file type for import.” I’ve tried bookmarks files in XML, HTML, and JSON, and all fail. What am I doing wrong?

Currently, only HTML is supported. A valid netscape bookmarks DOCTYPE is expected and a UTF-8 encoding meta tag doesn’t hurt. You can try adding some dummy bookmarks and exporting them, it should be able to reimport that file without problems.

I tried importing an HTML file, and it still returned the “Unsupported file type for import” error.

So, I exported my Nextcloud bookmarks, added the bookmarks from my other HTML file to that file, and re-imported. Seems to have worked. That’s a frustrating way to have to do it.

I understand. Where does your export come from?

https://pinboard.in

And what does it look like?

<!DOCTYPE NETSCAPE-Bookmark-file-1>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=UTF-8">
<TITLE>Pinboard Bookmarks</TITLE>
<H1>Bookmarks</H1>
<DL><p><DT><A HREF="https://google.com" ADD_DATE="1564415983" PRIVATE="1" TOREAD="0" TAGS="google">Google</A>
</DL></p>

I’m sorry for the delay, I just stumbled upon the issue I had created for this last year and checked again. This seems to be fixed. i.e. this should work in the upcoming version of the bookmarks app and I’m pretty sure the latest release also has the fix :crossed_fingers: