Cant get to any settings/admin pages - get 404

Nextcloud version: 27.0.1
Operating system and version (eg, Ubuntu 20.04): docker: nextcloud:latest (at the time)
Apache or nginx version (eg, Apache 2.4.25): built into docker, but for reverse proxy using nginx 1.18.0
PHP version (eg, 7.4): docker built in

The issue you are facing:

I used a docker compose for version 27.0.1, i have configured everything, and file syncing, webUI, user creation all work as expected. except i cannot get to any path inside the /settings/admin/ path. it returns a 404. the User setting show up as expected. I used to have a much older version, and i re-used my reverse proxy config.

Steps to replicate it:

  1. go to /settings/admin

The output of your Nextcloud log in Admin > Logging:

cant get thereq

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'datadirectory' => '/data',
  'instanceid' => 'oczipd0bjq8h',
  'passwordsalt' => 'XXXXXXXXX',
  'secret' => 'XXXXXXXXX',
  'trusted_domains' =>
  array (
    0 => '',
    1 => '',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'overwriteprotocol' => 'https',
  'overwritehost' => '',
  'overwritewebroot' => '/cloud',
  'dbname' => 'db',
  'dbhost' => '',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'user',
  'dbpassword' => 'password',
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'filelocking.enabled' => 'true',
  'memcache.locking' => '\\OC\\Memcache\\APCu',

nginx reverse proxy section:

MAin section:

server {
        listen 80;
        return 301 https://$server_name$request_uri;  # enforce https

server {
        listen 443 ssl;
        add_header Strict-Transport-Security "max-age=31536000; includeSubDomains" always;
        #ssl_certificate /etc/letsencrypt/live/;
ssl_certificate /etc/letsencrypt/live/; # managed by Certbot
        #ssl_certificate_key /etc/letsencrypt/keys/0000_key-certbot.pem;
ssl_certificate_key /etc/letsencrypt/live/; # managed by Certbot
        ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
      ssl_prefer_server_ciphers on;
        ssl_ciphers "EECDH+AESGCM:EDH+AESGCM:AES256+EECDH:AES256+EDH";
        ssl_session_cache shared:SSL:10m;

location / {

        root /usr/share/nginx/html;
        index index.php;

Specific Nextcloud section:

location /cloud/ {
  auth_basic off;
  proxy_set_header Host $host;
  proxy_set_header X-Real-IP $remote_addr;
  proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
  rewrite ^/cloud(.*)$ $1 break;
  client_max_body_size 10G;

this is a far smaller config from what ive seen online, but it worked fine on a version 23 install, so i never changed it.

again, everything outside of that setings/admin. path works fine.