Can't get new snap install to work after importing export from old working snap

I had this old installation on Bodhi 16.04, the NextCloud (NC) snap is I think 26; It always updated itself fine.
Because I can’t update Bodhi in place and all examples are with Ubuntu I decided to export all data using nextcloud.export (done), install Ubutu 22.04 on another disk (done), install NC snap (done), connect the old disk to USB and copy the exported folder to the backup folder so it can be imported (done) then import it with nextcloud.import (done); all without errors.
I did this twice; once following some instructions of “manual install” " on the command line in order to avoid a small window where the administrator registration page would be accessible to anyone visiting your server’s IP address or domain name" and following the rest of that tutorial for ssl, hosts, etc. and another time just standard making an admin account at the browser admin login prompt.
Both times averything worked fine but I can’t connect to it using a browser at all, local or remote, through IP or url.
I should mention that I have an apache2 reverse proxy running on another machine (for another web site and a Home Assistant installation) that worked fine and I didn’t change anything to it.
Another question nags me: At which point should I do the nextcloud.import? After installing the snap? After doing the manual or browser-admin login (which seems to do a lot behind the scenes?
I’m ready to give up :frowning:
I liked (most of) it when it worked but …
The warning that export/import is experimental is not a good omen, but it seemed to all work.
You’d think after so many years this should be a thing that should just work.
I’m far from a linux expert but generally find ways to get things done. This… I don’t even know where to start.
Thank you.

What, precisely, do you mean by “can’t connect”? What happens? Are you using the same URL you used to finish the initial setup (i.e. to make the admin account)?

Also, is this URL (whether IP or hostname based) via your proxy or does it bypass your proxy?

Thank you jtr.
I get (for example):
# Service Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Apache/2.4.41 (Ubuntu) Server at myExternalAsusComm.comBasedUrl Port 443
Of course I tried all possible ways to connect: From Local machine, from LAN using Lan IP and all ports I could think of (old installation was on 443; I tried 443, 8443, 4443) and through the hostname that used to work through the reverse proxy.
Only “positive” thing that happens is that I think it sometimes (I tried many things) got as far as it “extending” the URL such:
https://myurl.asuscomm.com/index.php/login (trying to make the forum NOT generate a preview).
(i.e. it adds the “/index.php/login”) but I wonder if that’s from the browser remembering stuff although I think it also happens when I go to ythe LANaddress:port