Can't get federated sharing to work

I run two NC11 servers and wanted to use the federated share feature between them.

When I create a share it accepts it and on the other server-side user-interface (webinterface and desktop client) I get a notification that a share with me was created. But I can not find this share inside this user account.

In the server logs I can not find any errors.

When I create a share directed to another server-installation, where should the remote-user see this share within it’s account?

From https://nextcloud.com/federation/ it shows a question-message that asks if I want to add this share to my account. I do not see such a message.

In the files apps you normally have on the left a category which is called Shared with you.

ok, there I have nothing

I now found an entry in the NC server log regarding federation:

GuzzleHttp\Exception\ClientException: Client error response [url] https://kunterbuntcloud.de/ocs/v2.php/apps/federation/api/v1/request-shared-secret?format=json [status code] 400 [reason phrase] Bad request

Possibly:

Bump. I was hoping this would have been fixed with 11.0.3, but it’s not. Any news at all? I’m surprised such a flagship feature is so broken. I’ve only been having the “yellow light” for the last month now

almost one year later, meanwhile upgraded both servers to NC12, still the same issue.

For this topic, I found this topic:


where it is said that some things were fixed for NC12.

A similar error was created by a wrong configuration of the .htaccess:

For myself it has been working between two setups. You could try with one demo server if that works (either share stuff with or share stuff from).