Can't find RainLoop in NextCloud Apps


#1

Hello,

I have recently installed NextCloud on my server using the web installer. I have been reading that people install RainLoop from NextCloud Apps, but I can’t find it now or at least on my app store.

Any ideas what’s happening? was it removed from the app store recently? I also noticed that this page went down: https://apps.nextcloud.com/apps/rainloop

However, looking at a cached version of this page: http://webcache.googleusercontent.com/search?q=cache:xutQYvoD0U0J:https://apps.nextcloud.com/apps/rainloop&num=1&client=firefox-b-1-ab&hl=en&gl=us&strip=0&vwsrc=0, I can see that NextCloud 13 had it…


#2

I think Community apps come and go … ownCloud still has it: https://marketplace.owncloud.com/apps/rainloop


#3

Can I actually install it from ownCloud on my NextCloud server? Can you please provide more information on how I can install it if it’s not in the NextCloud App Store?

Thank you!


#4

The developer deprecated his app (which is not identical with the Rainloop project) providing Rainloop for Nextcloud and is looking for a new maintainer:


#5

The no-longer-current maintainer is afraid of ‘rampant security issues’ ( https://github.com/pierre-alain-b/rainloop-nextcloud ). So, it seems to be time to concentrate all efforts to fix the official beta mail app.

That’s the way it goes sometime.


#6

Rainloop still uses mcrypt which was removed from PHP 7.2. Passwords are stored in cleartext:

Most alternative mail clients for Nextcloud and Owncloud were abandoned sooner or later (like for example Roundcube). Aside from that, the Rainloop app requires some work to make it compatible with Nextcloud 14+ in the future.


#7

I will hope that someone will continue this job.
Rainloop was my favorite - using mail in nextcloud.

The “official mail app” is not an option. Rainloop looks better, feels better and could be managed by many of my users without any help.

Tried mail in Version 0.8.3 and - nope couldn’t connect to my IMAP Server with same credentials as used in rainloop. (yes disabled rainloop app before installing mail)
Have disabled mail directly again after that bad try!!!

To have “mail” on the same level as rainloop there should many many work to do i think


#8

Totally agree!

I used Rainloop in NC more likely than my Outlook 2016. It worked so smooth and erverghing was fast (i.e. the search)

Please try to bring back Rainloop!


#9