Can't create new user

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 18.0.0 Build:2020-02-04T23:01:48+00:00 7bc14ae1df0a9dd3bc6b2023d8633a6f7eb4d8fe Same with the stable NC18
Operating system and version (eg, Ubuntu 17.04):CentOS Linux release 7.7.1908
Apache or nginx version (eg, Apache 2.4.25): nginx 1.17.8
PHP version (eg, 7.1):PHP 7.4.2

The issue you are facing:I can’t create new user on webview. When clicking add new user, only admin information line moves down.

Is this the first time you’ve seen this error? (Y/N):N Saw this with latest stable NC18 too.

Steps to replicate it:

  1. Open your Chrome browser version 79.0.3945.123
  2. Go to your Nextcloud
  3. Try to create new user

The output of your Nextcloud log in Admin > Logging:

Nothing about this

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => '007',
  'passwordsalt' => 'NaCl',
  'secret' => 'xx7',
  'trusted_domains' => 
  array (
    0 => 'mydomain.com',
  ),
  'datadirectory' => 'data above public directory',
  'dbtype' => 'mysql',
  'version' => '18.0.0.10',
  'overwrite.cli.url' => 'https://mydomain.com',
  'memcache.local' => '\OC\Memcache\Redis',
  'filelocking.enabled' => 'true',
  'memcache.locking' => '\OC\Memcache\Redis',
  'redis' => array(
     'host' => '/var/run/redis/redis.sock',
     'port' => 0,
     'timeout' => 0.0,
      ),
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost:3333',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => 'nextcloud',
  'installed' => true,
  'mail_from_address' => 'noreply',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => 'mail.mydomain.com',
);

The output of your Apache/nginx/system log in /var/log/____:

Nothing about this

If I click New user, admin line goes down. Another click and comes up again.

Any script blockers active or other add-ons?

Can you try with another browser?

Hi rakekniven!

I have uBlock Origin, but it’s not in use on my Nextcloud page.
I tried other browsers with my mobile phone. Didn’t have others right now.
Brave browser ver 79.0.3945.136 (chromium based) Can’t create new user.
Kiwi browser ver 77.0.3865.92 (chromium based) Works.
Firefox browser ver 68.4.2 Works.

I didn’t actually created a new user yet. But now I got boxes where to enter user name etc. with Kiwi and Firefox.

I didn’t install recommended apps when I installed Nextcloud. If that matters…

So, please check your add-ons.

I think the Brave browser blocks Javascript by default. Just enable that in the browser preferences.

The Brave’s security setting is turned off. (lion head after the url is grey) Script, ads and others shows 0 blocks. User add not working.
No extra blockers added.
Have to continue tomorrow with Chrome. It’s on restricted Chromebook. Just user or similar rights. So I can’t do much with it.

Now testing with Chromebook and Chrome browser.
Javascript was and is enabled.
Everything worked on incognito tab.
I deleted cookies from my nextcloud site on normal tab. No help.

What in this case makes incognito and normal tab so different that it will work only on incognito?

This was an interesting case. Just didn’t have enough time to look for the exact reason for this.
I just did a rough deletion on the Chrome. I choose basic deletions and files from the beginning. So history, cookies and other info and pics and files in the cache were deleted.
Actually cookies from my Nextcloud were deleted earlier (post before) so the reason wasn’t a corrupted cookie. I have installed Nextcloud on a new server, but domain is the same old. So maybe there were something old data left in the cache from the older Nextcloud. I had latest NC17 with different PHP on a one server. Then I did training setup with NC18 and PHP 7.4. After it was fine I did one more setup with latest NC18 daily and PHP 7.4. Every time I have used the same domain. And because the problem was only seen on my two browsers, which I use daily, I bet both have and had the same bad data in the cache.
I didn’t delete Brave’s cache yet. So if some one gives me a guide how to dig the data, I can try to find exact reason. :crazy_face: