Can't create an external storage to OVH Object Storage Openstack

Hi everybody,

I’m trying to setup an external storage to mount an Object Storage provided by OVH and I can’t find the good settings.

This is what I’ve tried :

Do you have any idea ?

Thank you !

I just created an account to amplify this because I’m experiencing the same issue and every single post that gets created on this seems to be ignored and unresolved.

Both this (Docker) and another Nextcloud (Snap) I’m testing with have connected with many different S3 storages but never OpenStack, I know for a FACT that my credentials are correct because I’ve connected to the OVH storage successfully using CyberDuck.

I’ve tried multiple variations of everything, I’ve exhausted all configuration options, it just WON’T work!

It also seems as if it’s missing an option. I’ve seen previous configurations including one on these forums where a user had 9 input fields on V3, why are there only 8 now???

I have a feeling that the lack of this magical 9th input field is what’s causing the issue here.
When I got it working with CyberDuck I entered it like this:

<project_id> :default:<horizon_username>

Then adding the same as I entered into NextCloud (horizon password and auth url).

I understand that a lot of work goes into this project, but one has to ask what is the point of putting all the effort in to integrate OpenStack when the documentation isn’t even updated so that a user could even figure out how to do any of this in the first place. And the settings have changed multiple times through the different NC versions.

I’ve fixed it upgrading to nextcloud 19 beta. The fix is here : https://github.com/nextcloud/server/pull/19540

Thanks for sharing :+1:
There’s no way I’m updating to a BETA release however as I’m running an instance in production that requires as much mission critical stability as possible.

It is good to know this problem has been recognized and I’m not crazy!
I had considered my options and decided to add another space included under my existing Digital Ocean spaces package for their Frankfurt server and opt for that instead.

I found that once I added Redis + Disabling File locking, it became very stable. Which was the original reason I had wished to try openstack instead.

I may recommend others do the same if they’re concerned about this issue.

On a side-note, I’ve noticed not all Object Storages are created the same.
Some, like Exoscale don’t seem to support encryption whilst others such as Linode’s offerings are downright unstable when I’ve used them with NC.

Happy travelling fellow NextCloud(ers?)

Hi there,
@gbprod, have you been able to add an exernal storage from OVH object store?
I’ve just updated to nextcloud 19, so has to benefit from the fix mentioned above; but still struggling to find the correct values to set the storage up.
If you could share which parameter you’ve used, that would help me !
Thanks,
Fabien

I eventually found out how to fill the OVH object store information,
see in below screenshot:


where:

  • Bucket is the object storage name,
  • user/password are the ones you have set in the “Users & Roles” area, with role “ObjectStore operator”.
  • Tenant name is the project number (from openstack RC file>OS_TENANT_NAME that you generate on the Users&Roles panel)

Hope it’ll help !
Fabien

1 Like

@Fabi1 Thank you! This is the only place on the Internet I was able to find the correct configuration for OVH OpenStack Nextcloud setup.