Can't create a folder named "sexy" lol

Support intro

Nextcloud version (eg, 20.0.5): 23.0.1
Operating system and version (eg, Ubuntu 20.04): Ubuntu 20.04
Apache or nginx version (eg, Apache 2.4.25): 2.4.25
PHP version (eg, 7.4): 7.4

The issue you are facing: I cannot create a folder named “sexy” in Nextcloud, which happened to be the name of one of my subfolders. I’ve tried creating it manually, uploading it, uploading it as a subfolder… each time it fails. If I name the folder anything else, the upload works. This does not even make sense to me.

Is this the first time you’ve seen this error? (Y/N): N

Steps to replicate it:

  1. Create a new folder
  2. Name it “sexy” or anything with the word “sexy” in it.
  3. “Could not create folder”

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):


The output of your Apache/nginx/system log in /var/log/____:


have you tried that from OS-level?

I had not, but I just tried and can create any folder I want to in /var/www/nextcloud/data/user/files, including one called “sexy” :rofl:

ummm I just tried on NC-level and had no problem creating such a folder…

what if you’d try creating other bad-named folders? (you know the best which words to try, I bet :wink: )

1 Like

Have you checked, if this folder existed in the past? Maybe check the trash bin and delete this folder if it exists in there.
Otherwise you probably have to look into the Database and see, if there is an entry for the folder which doesn’t exist on the filesystem.

1 Like

having deleted a sexy-folder and having it in the trashbin it’s possible for me to create other sexy-folders…

1 Like

It does seem to be related to the database. I’m playing around with the file_cache and filecache_extended tables right now. It was holding onto something in the db that I couldn’t see on the front end. Thank you!


Usually creating a folder with the same name like a deleted one, is also working for me.
But I had this issue once, that I had to delete the folder from the trash bin first. I guess, the DB wasn’t updated correctly at some point.
I just wanted to mention that, in case something like that happened to gabeyww as well :slight_smile:

1 Like