Cant connect using freedns subdomain. have forwarded ports and entered hash. cant get it to work. help?

Modem /router:

(Netgear R7000) behind (fibre-to-node modem)

Device connection:

nextcloud device connected to R7000 by cable

Static address:

Nextcloud device has static LAN IP set on R7000

Port fowarding:

Netgear R7000 WAN -> Port Forwarding -> looks like this

(port forwarding set to ‘enabled’ in WAN - > Internet Settings)


FreeDNS - I have created a subdomain, type ‘A’

Nextcloud settings, subdomain:

Nextcloud -> Networking -> FreeDNS - have entered FreeDNS domain and update hash. It reports its working.

Nextcloud -> config -> trusted domains - have entered FreeDNS domain name

When I try to connect to Nextcloud from the FreeDNS domain, I get connection timeout.

checking port 80 from - connection timeout.

Can anyone advise me on what else I need to do to make it connect?