Can't connect to OnlyOffice in Nextcloud. server is reacheable

Hello Everybody,
I have my OnlyOffice server running and reachable via the url https://office.url.com/welcome. It shows the Document Server is running screen.

But I can’t get the Nextcloud integration right. When I put the URL in the Document Editing Service Address, I get the following error in the logging screen of Nextcloud:

Settings screen:
OnlyOffice

Errorlog:

GetConvertedUri on check error: Error occurred in the document service: Error while downloading the document file to be converted.

I don’t have and cannot find any other errors relating this subject.

Here is my office-ssl.conf. I checked several times, but it seems ok, compared to the online examples I found.

<IfModule mod_ssl.c>

ServerTokens Prod
SSLStaplingCache "shmcb:${APACHE_LOG_DIR}/stapling-cache(150000)"
SSLSessionCache "shmcb:${APACHE_LOG_DIR}/ssl_scache(512000)"
SSLSessionCacheTimeout 300

<VirtualHost *:4433>
ServerAdmin ***@protonmail.com
Servername office.url.com
ErrorLog ${APACHE_LOG_DIR}/office.url.com.error.log
CustomLog ${APACHE_LOG_DIR}/office.url.com.access.log combined

<IfModule mod_headers.c>
Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains"
#Header always set Referrer-Policy "no-referrer";
Header add X-Frame-Options "ALLOW-FROM https://url.com/"
SSLProxyEngine On
AddDefaultCharset utf-8
HostnameLookups Off
UseCanonicalName Off
ProxyBadHeader Ignore
KeepAlive Off
ProxyPreserveHost On
ProxyRequests Off
ProxyTimeout 600
ProxyReceiveBufferSize 4096
SSLCipherSuite EECDH+AESGCM:EDH+AESGCM:AES256 #Etcetera
SSLProtocol All -SSLv2 -SSLv3
SSLCompression Off
SSLHonorCipherOrder On
</IfModule>



SSLEngine on

SSLCertificateFile	/etc/ssl/certs/office.crt
SSLCertificateKeyFile /etc/ssl/private/office.key

SetEnvIf Host “^(.*)$” THE_HOST=$1
RequestHeader setifempty X-Forwarded-Proto https
RequestHeader setifempty X-Forwarded-Host %{THE_HOST}e
ProxyAddHeaders Off


SSLProxyEngine on
ProxyPassMatch (.*)(/websocket)$ "ws://127.0.0.1:81/$1$2"
ProxyPass / "http://127.0.0.1:81/"
ProxyPassReverse / "http://127.0.0.1:81"


SSLProxyVerify none
SSLProxyCheckPeerCN off
SSLProxyCheckPeerName off
SSLProxyCheckPeerExpire off

</VirtualHost>
</IfModule>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

I hope someone has a clue were to find the answer to get this Working?

Hey I have the same problem.
Do you have a solution right now?

I found a way.
I check the docker error log
-> docker logs NAME| grep err
and there I found this:

[ERROR] nodeJS - dnsLookup error: hostname = mydomain.eu

To solve the problem do this:
docker exec -it NAME bash
nano /etc/hosts
0.0.0.0 mydomain.eu service // enter instead of 0.0.0.0 your ip

save and it works for me

Hi @Benedikt

Thanks for the advice. With “your ip” do you mean the local network IP address like 192.168.x.x or localhost 127.0.0.1?

I mean the ip address of your nextcloud server.