Can't connect on local network - Trusted domain problem?

Nextcloud version:
Operating system and version: Ubuntu Server 18.04 LTS
Apache or nginx version: Apache/2.4.29
PHP version: PHP 7.1.33

So, I am trying to connect to my server locally but its not working. However, outside my lan I can connect without any problem.

When I try to connect i get this page:

So, I really don’t know what to do, I searched the internet and found nothing that could solve my problem :frowning:

What I’ve tried so far:
Added my local ip to the config.php file

$CONFIG = array (
'trusted_domains' =>
  array (
    0 => '',
    1 => '',
    2 => '<public-ip>:4433',

The network I’m in is the Also, I’m not using the default HTTPS port because I don’t have access to the router settings and the network admin don’t let me port forward the 443 port. The 10.x.x.x network is the network the router connect to the WAN is.
I’m using is Opera

That is the first time I’m facing this problem after the initial configuration
Thanks in advance!

Strange, because these kind of questions are raised in this forum on a regular base?! It might be worse to use the search function of this forum as a second try :wink:

You want to say that the ip address of your Nextcloud server is “” and that it is listening on port “443:wink: What url are you exactly entering in the web browser if you try to access the server?

my 2 ct:

i dunno if

would be neccessary or even allowed. try without.

if this is a fresh installation why do you use an outdated (and thus insecure) version? i’d try a newer one. nc 16 or 17. nc 16 would run with your php-version… nc 17 could need an update on that.

Well… I tried that :confused:

I’m entering

Oh wow I didn’t even realize… Thanks for letting me know, I’ll update as soon as possible. I just followed a tutorial that was telling me to install that version and didn’t pay attention on that. Thanks!