Can't add account in initial client wizard install with latest client

#1

I’m having this issue consistently on different computers across all accounts. I download the latest version of the desktop client (including the latest RC1), and attempt an install. The wizard prompts me to enter my Nextcloud server URL and login. It then pulls up the web interface of the Nextcloud server. I can see all my files…it’s basically the web interface, but I can NOT click “next” to complete the process of connecting the account. The button is greyed out. I just want to add the account so I can sync my folders! I’ve been having to use older versions of the client because all the newer versions after 2.3.3 don’t work.

#2

Welcome to the forums @bond00

Please could you tell us what operating system the client is installed on? Can you also check the nextcloud log, if there are any error/warning messages?

Thanks in advance

#3

Your idea of checking the logs got me onto something. I noticed an error that the server was returning a 404 for remote.php and status.php. I run Nextcloud out of a /nextcloud/ folder on Apache2…and setup a 302 from the root to /nextcloud/. To fix the issue, I created a new vhost and set the Nextcloud folder as the web root folder. I then logged back into the client, and it worked great! I’m guessing older client versions followed 302 redirects. In this case, I just switched to the web root folder. Thanks for pointing me in the right direction!

#4

Seems to be a problem with the latest MacOS Client and SSO.
After login the page hangs.
Alternative login using app token works.
Does work with Win10.
V16.0.0