Can't access WebDAV via Browser

Nextcloud version (eg, 10.0.2): 12.0.2
Operating system and version (eg, Ubuntu 16.04): Ubuntu Server 17.04
Apache or nginx version (eg, Apache 2.4.25): Unsure, installed today.
PHP version (eg, 5.6): 7.x Also unsure, installed today.
Is this the first time you’ve seen this error?: Yes

Can you reliably replicate it? (If so, please outline steps): Yes

The issue you are facing:
I cannot connect to my Nextcloud installation via WebDAV. When I connect to my server using the normal GUI it works as expected.

When I connect using webdav (
I am presented with a login screen, so I login as my admin account and am presented with a page that reads

Not Found

Technical details

_ Remote Address: x.x.x.10_
_ Request ID: “xxxxxxxxxxxxxxxxxxxxx”_

Nextcloud – a safe home for all your data

This is the case whether I connect locally or remotely. I used to connect to a WebDAV share from a FreeNAS installation and would very much like to continue using WebDAV.

The output of your Nextcloud log in Admin > Logging:

Nothing of note here. Trusted Domain errors prior to me correcting them, and a filed login from an incorrect password.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):


$CONFIG = array (
‘instanceid’ => ‘example’,
‘passwordsalt’ => ‘example’,
‘secret’ => ‘example’,
‘trusted_domains’ =>
array (
0 => ‘x.x.x.3’,
1 => ‘’,
2 => ‘’,
‘datadirectory’ => ‘/var/www/nextcloud/data’,
‘overwrite.cli.url’ => ‘’,
‘dbtype’ => ‘mysql’,
‘version’ => ‘’,
‘dbname’ => ‘nextcloud’,
‘dbhost’ => ‘localhost:50003’,
‘dbport’ => ‘’,
‘dbtableprefix’ => ‘oc_’,
‘mysql.utf8mb4’ => true,
‘dbuser’ => ‘oc_example’,
‘dbpassword’ => ‘example’,
‘installed’ => true,

I didn’t include Apache logs because I wasn’t sure which file was being requested as there are a few in that folder. The only thing strange about my config.php is the port line.

Any help is greatly appreciated.

What does your apache virtualhost look like? Did you follow this?

Hey thanks, my file is identical to the one you posted. During that
portion of the manual installation I copy and pasted that into the file so
I know I didn’t type it wrong.

Thanks for your help

Check this logfile /var/log/apache2/error.log
What’s the output after you attempt to access it?

I just attempted to access WebDAV at 9:51 and got the same response I’ve been getting. I opened the file you specified and the most recent line was at 6:25 this morning.

Thank you for your help

my nc-instance (v12.0.2) gives out this path for using webdav

and another thing that came to my mind… r u using a linux webdav or mac or windows or android or ios? that didn’t really got clear for me.

I’m using the path I posted because that’s what I found in the nextcloud
documentation for accessing webdav. I tried your path and got the same
message that webdav can only be accessed by webdav clients like the
nextcloud sync.

I’m unsure if it has something to do with virtual host. I’ve read a lot
about it but I can’t find a concensus on which file that is. My
sites-enabled nextcloud.conf file is identical to what nextcloud says to
use during installation, but all the guides I’ve found add virtual host and
ssl cert info.

I can’t find where to specify the path to my let’s encrypt certs.

Thank you for your help. Much appreciated

I’m confused. You said the link gave you a “not found”. If you get the message “This is the WebDAV interface. It can only be accessed by WebDAV clients such as the Nextcloud desktop sync client.” then that means it’s working.

Have you tried this?

I’ve seen that page, but didn’t know if the changes we’re necessary.

When I ran a webdav share in FreeNAS I could connect via web browser and
view all my files. I assumed this was the intended use for nextcloud as

I also cannot get windows to make a network drive to it, or an Android app
to connect.

which webdav-client do you use? on which platform?

I’m not using a client. I’m using a web browser. I guess I misunderstood
how it works. With my webdav share via FreeNAS I could connect via a web
browser and view all my files. Download them, watch videos, open pictures

Small update. Using the second path specified, Windows Explorer connects just fine. That’s excellent news. I still can’t access my files directly with a web browser. It’s not a huge deal, but if anyone has any ideas about enabling that functionality I’d really appreciate it.

Thanks for the help everyone

Just as a side note: Have you checked for any problematic apache modules, such as e.g. mod_security?

I have not. I’m not sure how to do that.

Have a look at the sections “Web server and PHP modules” and “Troubleshooting WebDAV” at the General Troubleshooting doc page:

Check your enabled modules with:
sudo apache2ctl -M

You can easily disable problematic apache modules in the shell via:
sudo a2dismod MODULENAME

Example (for mod_security):
sudo a2dismod security2

Restart Apache when you are done with disabling modules:
sudo /etc/init.d/apache2 restart

You can easily enable the modules again with:
sudo a2enmod MODULENAME

Please note that some major linux upgrades might re-enable modules, which had happend in my case. It took me quite a while to figure that out…