Can't access Nextcloud server from outside the network - wireless router


This is my first time writing here and I am an absolute a newbie for home servers so apologies if I am not mentioning something important that could help solving the issue or if I am writing stuff that are totally irrelevant.

I have been able to install and setup the latest version of NextCloud on Ubuntu server 20.04 on a raspberry PI 3 following the bit in the official NC manual that covers the installation process on Ubuntu. Everything is up and running but I am only able to access the server from within the network, using the IP address that is assigned to the PI. Here, I have setup an account and I have access to all the features. However, I am unaware of how to access the server from outside the network, that is why I am writing here.

I am using an EE 4G wireless broadband with an EE 4GEE router. I am only using this because there is no fibre optic in my area and ADSL is just way slower. EE customer service is embarrassingly uninformed and just generally useless so I would like to avoid contacting them unless you advise me otherwise.

In the router settings, I was unable to find anything related to DNS settings. What I can see in the advanced settings of my router’s admin interface that may be relevant to solving my problem, based on my limited knowledge, is:
Configure WAN
WAN Ping
IP filter
Virtual server

… could any one of these be of help?

What I can set up in the “virtual server” tab is:
Wan port
LAN Ip address
LAN port

… could this be useful? After endless googling, I have found out that I have to open port 443. So I went to the “virtual server” tab and I complete the fields with the server’s IP address in the “LAN IP address” field, I set both WAN and LAN port to 443 and status to “on”. I also tried the public IP address in the LAN IP address field but no luck. I am certain that this is all terribly wrong but nowhere else I could find anything that mentions “port” in the router settings… And the more I google the less integrity I can find in my knowledge, so basically, I have no idea what I’m doing.

I am aware that the IP address of my computer is assigned by the router and that it is not a publicly accessible address and starts with 192. (I am also aware of the fact that it changes every few days or so and I would like to sort that out too but one thing at a time…) I have googled up “what is my ip address” and have seen a different set of numbers that started with 213. I thought this would be my public IP. Am I mistaken? Or is it my router’s public IP, is it all really the same?

Oh and I have also added that particular public IP address to the trusted domains in the config.php, even with “https” and “/nextcloud” added at the end but still unable to connect from outside the network. I assume that the problem is in the router settings because I do not even see the blue nextcloud screen that complains about the domain not being trusted. All my browser says is: connection timed out.

Please let me know what other information I should provide in order for my issue to be solved. I apologise again for my lack of knowledge in the matter. Any help given will be greatly appreciated.

Best wishes

Some customers do not give the users an external ipv4 address (e.g. DS Lite). Then it could not work. Do you really have an own ipv4 address?

If you have an own ipv4 address you must configure in your dmz the forward from :443 to your internal server:443 . Then it must possible from outside: https://external-ip but with an certificate error.

1 Like

Hi, thank you for your reply!

I have now checked it on this link you sent me and it says Ipv4 supported. Ipv6 is not available, but that shouldn’t be a problem, right?

Now, I went into the DMZ settings but in there, I can only see one box: “DMZ host IP address”. I am uncertain how to do port forwarding.

If you could be of further assistance, that would be greatly appreciated!

Thank you for your help

Hi @broskobandi

If you are using a 4G conection you are most likley behind a CGNAT. This means that your router is not receiving a publicly available IP address, therfore port forwarding is not possible.

But there are other ways to make services on your local network publicly available like ZeroTier or ngrok, but i have no experience with them. Maybe this thread can help, to point you in the right direction…


Thank you for your reply, it literally solved all my issues!

Best wishes