Cant Access NextCloud Outside of My Own Network

So my ISP has port 80 open i have port forwarding set up to it. but if i type my domain for example outside of my network it will not connect. If i type just it will not work unless I’m connected to my network. I have tried like 6 different ports and i add the address to the trusted domaisn for example is a trusted domain but it will not work unless I’m connected to my personal internet can someone help me please? I’m losing my mind over this. I used a snap to install NextCloud here is the link to it.

Sounds like a DNS issue. Do you have a FQDN setup and pointing to your IP instance?

Also be aware that some ISPs in some countries black port 25, 80 and 443 for residential clients.

You may try a vps or another ISP to run your tests.


Are you asking if I forwarded my DNS to the ip that the server is running on? Cause if so then no. I’m in america but where I live I can’t really switch internet companies kind of a monopoly only one provider. And what do you mean by VPS?

Also I have tried connecting to the ip from outside my network and that doesn’t work either only works on same network that the server is on.

digital ocean would be a vps (or provides vps. they call them droplets.)

could you please define that? error message? timeout? blank page in browser?
“doesn’t work” can mean you didn’t setup your isp’s router correct. (NAT) it can also mean you didn’t setup your web server correct.

did you check it? just start a default web server listen to port 80.

It just loads infinitely and then after like 15 minutes just gives you a blank page but still says loading. I would rather not have a vps would rather DIY it all. Also I’m rather new to Linux so could you point me in a direction to create a test webpage?

which os are you using: debian or ubuntu?
virtual server or real hw?