Can't access login, error protocol http

Nextcloud version (eg, 18.0.2): 19.0.3
Operating system and version (eg, Ubuntu 20.04): mac os 10
Apache or nginx version (eg, Apache 2.4.25): Linux 4.14.154-ovh-vps-grsec-zfs-classid x86_64
PHP version (eg, 7.1): 7.3.20

The issue you are facing:
I’ve install nextcloud on my serveur, all was working fine. I’m tring to open it on an other computer, but I can’t ! When I’m going on url, can’t see login page and have ERR_HTTP2_PROTOCOL_ERROR in console.
Can’t understand why it’s not same on my computer with same OS and browser…
Error is on Chrome, but same problem on FF with loading error on files.
Try it : https://cloud.laguildedupixel.fr

The output of your Nextcloud log in Admin > Logging:

no error today

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => 'xx',
  'passwordsalt' => 'xx',
  'secret' => 'xx',
  'trusted_domains' => 
  array (
    0 => 'cloud.laguildedupixel.fr',
  ),
  'datadirectory' => '/home/laguildepv/cloud/data',
  'dbtype' => 'mysql',
  'version' => '19.0.3.1',
  'overwrite.cli.url' => 'https://cloud.laguildedupixel.fr',
  'dbname' => 'xx',
  'dbhost' => 'xx',
  'dbport' => '',
  'dbtableprefix' => 'xx_',
  'dbuser' => 'xx',
  'dbpassword' => 'xx',
  'installed' => true,
  'mail_smtpmode' => 'sendmail',
  'mail_sendmailmode' => 'smtp',
  'mail_smtphost' => 'xx',
  'mail_smtpport' => 'xx',
  'mail_domain' => 'xx',
  'mail_from_address' => 'noreply',
  'mail_smtpsecure' => 'ssl',
  'defaultapp' => 'apporder',
  'default_language' => 'fr',

);

thanks a lot !

I use Mozilla Firefox (he uses for me HTTP/1) and the website works but it is very slow.

GET https://cloud.laguildedupixel.fr/index.php/apps/side_menu/css/stylesheet?v=2
[HTTP/1.0 200 Connection established 5501ms]

Perhaps you can disable HTTP/2 in browser and/or apache2 / websever.
Perhaps HTTPS/2 is wrong configured.

https://amielucha.com/http2-on-apache-installation-and-configuaration/

found solution with ovhconfig file ! now it’s working. Thanks !

Hi @estelle,

I also have the exact same problem on OVH hosting. Would you mind sharing your solution?

Thank you and bonne journée

Hello

Create a .ovhconfig file with

app.engine=phpcgi
app.engine.version=7.3
http.firewall=none
environment=production
container.image=stable

Great, it worked! Thanks so much. Merci de tout cœur @estelle