Can't Access After Fresh Install on Pi


#1

I just installed NC14 for the first time on a Raspbian Pi using the curl installation from the NC website. Once it completed, I got a not found error when trying to access http://IP/nextcloud, but when I accessed http://IP, I got the NC Activate screen. I clicked on the activate and then got into the system setup screen. This time I skipped the steps and clicked on Go to Nextcloud.

I then get the Untrusted Domain message. I added the IP to the config.php and now when I try to access http://IP/nextcloud it goes to the NC login screen. But I have not yet configured an Admin account or users, so I have no idea what the login is at this point. I have been searching the internet for hints but no luck so far. Can anyone point me in the right direction? Thanks!

UPDATE: Have tried ‘ncp’ and "ownyourbits’ on the login screen, but keep getting “Wrong Password.”


#2

The passwords for user ncp are auto generated and shown on the activation screen.
If you did not save them, they are stored and can be (re)set from nc-admin and nc-passwd, which you can access through ncp-config in terminal (or ncp-web on yourIP:4443 if that page is still open)


#3

Thanks! I thought I had already tried both of those passwords (I did save them). I can get with the second one. However, I never saw the screen to determine where I want my data to be stored. I have a CIFS( (NAS) mounted and want that drive to be my repository. Other installation help shows that being asked at startup. Where do I go and is there a recommended process for moving the data repository?


#4

You can use nc-datadir for that.
Access through ncp-config
Check wiki for usage


#5

So, what’s the difference between ncp-database and ncp-datadir functions? I think I tried the ncp-database last time and got everything hosed up. Thanks!


#6

nc-database moves the the sql database
nc-datadir moves the data directory


#7

Thanks, OliverV! Sorry for the detailed questions, but I’m still not past this issue. I did try to use ncp-datadir to point to /mnt/nextcloud/data (a CIFS NAS share), but I get the error “Only etx/btrfs filesystems can hold the data directory”.
I’m trying to switch from Owncloud and it was able to use the NAS share as the data repository, so there has to be a way for Nextcloud to do it, right? I did see instructions for copying the data directory contents manually and updating the config file, but I’m hesitant to do that if I’m on the wrong track here.


#8

Where ever your data directory is going to be; it needs to be a Linux ext(4) or btrfs formated drive or partition.
Copying the files manually will not change that.

BTW detailed questions are fine, it are vague ones that are troublesome and hard to answer :wink:


#9

Thanks, OliverV! Actually, I did get it to work. I followed the instructions here under "Moving Nextcloud’s Data Folder and that worked fine. I’m still having issues with accessing from the client (can’t connect) and not being able to access http://IP/nextcloud, but I think that issue is related to my Mediacom router inability to port forward. I have a domain name from FreeDNS that points to my WAN IP, but it stops there. A TRACERT shows it hit the modem then stops. Since I already set up NC with external access, it is still trying to use the LetsEncrypt cert and there’s no connection from outside to inside.
So, I’m getting a new cable modem in on Sunday and will try again once I get a router that will port forward. If all else fails, I can always reinstall PI, NC, etc again.
BTW, I did order a 6 pack of SD cards so I can save baseline installs and have a quicker recovery when I mess things up… :wink: