Cannot use U2F as second factor

Nextcloud version (eg, 20.0.5): 27.1.6
Operating system and version (eg, Ubuntu 20.04): FreeBSD 13.2
Apache or nginx version (eg, Apache 2.4.25): Nginx
PHP version (eg, 7.4): 8.2

The issue you are facing:
I’d like to use a U2F device for a second factor for my authentication process. But I didn’t see the option on the security page of my user’s settings.
However I could use webauthn with a U2F device (but then I still need a second factor).

To reply to myself. What gave me a hint:

user@myserver: /ncdrive # php occ twofactorauth:state username
Two-factor authentication is enabled for user username

Enabled providers:
- u2f
Disabled providers:
- backup_codes
- totp
- yubiotp

Although in the interface it does not show up. Disabling was not possible:

user@myserver: /ncdrive # php occ twofactorauth:disable username u2f

In ProviderManager.php line 51:

  The provider 'u2f' does not exist'

Something is enabled that does not exist.

You can install different authentication backends via app store (security part), and I needed to install the twofactor_webauthn app. Still, there was no new option, however the readme gave a hint:

You can migrate old settings. And with the old mechanism, I had already used U2F in the past but with the old backend. And
php occ twofactor_webauthn:migrate-u2f --all

brought the old devices back. Then you can manage the devices again. Perhaps it helps someone with a similar issue.

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.