Cannot upload files bigger than 10 MB through WIN 10 client - error message: connection closed

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version :15.0.
Operating system and version :18.04.01
Apache or nginx version :apache 2.4
PHP version :7.2

The issue you are facing: Cannot upload files bigger than 10MB through Desktop APP. No problem with web GUI, get error message that “Connection is closed” by server

The output of your Nextcloud log in Admin > Logging:

nothing visible, no logs from server present

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => '',
  'passwordsalt' => 'xxxx',
  'secret' => '',
  'trusted_domains' => 
  array (
    0 => '',
    1 => '',
  'datadirectory' => '/media/storage1/owncloud',
  'overwrite.cli.url' => 'http://xx.xxxxx/nextcloud',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'nc',
  'dbpassword' => 'xxxxxx',
  'logtimezone' => 'Europe/Berlin',
  'logfile' => '/var/www/nextcloud/data/nextcloud.log',
  'loglevel' => 3,
  'syslog_tag' => 'Nextcloud',
  'log_rotate_size' => '104857600',
  'installed' => true,
  'theme' => '',
  'session_keepalive' => true,
  'maintenance' => false,
  'trashbin_retention_obligation' => 'auto',
  'mail_from_address' => 'server',
  'mail_smtpmode' => 'smtp',
  'mail_domain' => 'xxxxx',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'xxxx',
  'mail_smtpport' => '25',
  'mail_smtpname' => xxxx',
  'mail_smtppassword' => 'xxxxx',
  '' => 'stable',
  'filelocking.enabled' => 'true',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => '/var/run/redis/redis-server.sock',
    'port' => 0,
    'timeout' => 0.0,

The output of your Apache/nginx/system log in /var/log/____:

1 Like

Check your php.ini for the following variables and their values:

; Maximum allowed size for uploaded files.
; Should be higher than 10M
upload_max_filesize = xxx

; Must be greater than or equal to upload_max_filesize
post_max_size = xxx

You could do 512M for both.

Hi CFelix, both checked and value is in both cases 2G.
So this is not the issue. No problems while uploading through web gui, but WIN10 client is causing troubles.


Hallo CFelix, herzlichen Dank für die Bemühungen. Ich habe in der Zwischenzeit den Fehler gefunden. Es war die Sophos UTM, welche mit dem Firewall Protokoll den Upload aus dem WIN-Clienten verhindert hat. Nach Abstellen der Firewall geht der Upload problemlos.

DANK an alle.

Gruss F

Hey fraank,

thanks for coming back! I’m just going to translate this, in case someone else might run into a similar issue :slight_smile:

Funny enough, I had a similar issue with one of my clients the other day and it was the Firewall as well, which was preventing communication. I didn’t think about this one though answering your question.

If you want to use your firewall in combination with the client, you could setup a rule in your firewall allowing traffic in/out for the client.


…the issue was the Sophos UTM Firewall which was preventing the upload from the windows client. After the Firewall had been deactivated, the upload was working fine.

Bitte und schoene Grüße