Cannot upload files > 1mb after upgrade to NC15

I deleted my NC14 version and installed a fresh NC15 version using docker and mysql
all went fine, but one strange thing happens, which I did not had with the old NC14 version.

I can no longer upload files (PDFs) which are > 1MB. up to one MB all is fine. As sone the file size exceed 1 MB it will no longer upload.
I can start the upload, but it will never finish. No error message, No entry in the log files. it simply will not proceed.

The upload limit I have set to 1 GB, so that should also big enough to upload.

I have created a video showing the issue. The video can be found here: NC15 Upload issue

looking at the browser log, I do see this error:
core.js?v=91d3c9b7-13:formatted:3800 PUT https://cloud.xxxxxxx.xx/remote.php/webdav/Documents/test/lec18.pdf net::ERR_CONNECTION_RESET

I have solved my problem.
the reason was, that I am using a nginx proxy in front, which hat an upload limit set to 1MB by default.
I am using the cool docker nextcloud-docker-letsencrypt solution from Evert Ramos. By default the limit is set to 1mb. changing this solved my issue