Cannot update Nextcloud instance using updater.phar or web GUI

I’m on an instance running 17 trying to get to 20, and it’s saying in Overview that the server isn’t connected to the internet, but I’ve gone into the docker console and pinged google and and they work, so I’m really not sure how to go about this.

I tried looking up other threads but they all seemed to fix the issue in a way I don’t understand or know anything about. I haven’t done any weird DNS work on my router and I’m just using duckdns to get a domain on it, nothing fancy has been done on my side at all.

Updating the container/instance doesn’t update Nextcloud itself which I’ve already done.
I’m using OMV 4 with the Docker plugin for this too. I’ve replaced the image, but now I need to update.

In fact when I replaced the image all it did was go to 17 again instead of 20 which the image is currently at. Again, the updater tool which updates the internal side of things isn’t working because the container can’t seem to reach the update servers.

Anyone have any suggestions for troubleshooting docker instance internet access not working?

I’ve tried looking online for help with this but there’s really not any information about how networking works in Docker containers, at least in this specific instance. I didn’t manually turn anything off or configure any DNS server stuff, and I’m not sure how to configure it. once again, the instructions to update don’t cover my problem and how to fix it. I made a forum post because I couldn’t find anything anywhere else.