Cannot share folders

I have about a hundred fotos which I try to share with my son. The problem is: There is no option anywhere to share them. I want to share the folder which contains the images, but neither right-click nor any other way of accessing the folder or images shows the share-icon or any option that looks similar to an option to share. My son is a user at this nextcloud instance.
nextcloud runs on a NAS from Asustor, it’s at version 23.0.10, an update is planned, but I need to fix this sharing issue, because it’s ages old. I have NC installed mainly for the purpose of sharing, so it’s bekome useless to me after that option isn’t available any more. Since NC is about sharing, I guess that there is some setting that needs to be made, but I have no idea where to look.
Maybe someone here has an idea?

It can be a settings problem.

Administration → Sharing

If not please watch this video. Where is the problem? Post screenshots.

Thank you! I had been looking for settingsbut it’s sometimes quite confusing. In Settings there are two sharing icons, as I found out, one in the upper section in the left side menu, the other in the lower section of the left side menu. I had only seen the one in the upper section, and there was only a link for federated sharing or something similar. That didn’t help. The other menu item offered a bunch of options for sharing which were all enabled. What I have missed was a note in the top of the page stating that I first need to activate the file sharing app. Thus I went to the apps section, but I didn’t find any file sharing app. After some looking around I found in the left side menu the option “unactivated apps”, and after choosing that, I saw the file sharing app.
Makes me wonder why this basic feature was hidden in an inactive app which is comparatively hard to find (together with the message “activate the file sharing app”, a link to activate it could have been provided). Well, now it works.
The link you provided didn’t work, btw, and the video was little helpful, because it described only what I wanted to do but couldn’t. But the hint that it could be a settings problem was helpful. Thanks!

Sorry. But i am not a Nextcloud expert. Yes the app “File sharing” was another option (I knew, but I have not thought of it). But normally the app is activated because Nextcloud is a software to share files. :wink: But you can also use Nextcloud without this function, which makes sense in some cases.

But the problem is now solved. And that is the most important. continue to have fun with Nextcloud.

You are right! Thanks again for your help, it showed me the way! :slight_smile: