Cannot setup Nextcloud AIO according to tutorial (Ports)

I wanted to try Nextcloud for the first time today. On a Windows computer with the help of Docker before I start later on my own server via Proxmox.

I tried it according to these tutorial: Your Guide to the Nextcloud All-in-One on Windows 10 & 11! - Nextcloud
But a start of the container does not work. I have never had any problems with ports (15 years ago, yes).

Error invoking remote method ‘docker-start-container’: Error: (HTTP code 500) server error - Ports are not available: exposing port TCP → listen tcp bind: An attempt was made to access a socket in a way forbidden by its access permissions.

Hi, it looks like port 80 is already used on your system. In that case you could try to omit this line of the command: --publish 80:80 ^

Thanks that worked.

But still I can’t get any further with the ddns setup (New AIO instance).
I have entered there my ddns created by noip and I get from my to Nextcloud. But I keep coming back to the first setup page after login (/containers).

By the way, I have entered my public IP on noip.
And added the noip dyndns account via my router.
In addition opened, in the router the ports 443 TCP, 8080 TCP, 8443 TCP, 3478 UDP.

Can you post a screenshare of this maybe? I cannot follow what you are doing and what happens currently…

In the Nextcloud AIO setup, I add my domain that I created on noip - A-record of my internal-ip (192.168.X.X) →

It seems like the ip-address is set to an internal or reserved ip-address. This is not supported. (It was found to be set to ‘192.168.X.X’)

Or do I add nextcloud.noip.mydomain instead, then I get the message:

DNS config is not set for this domain or the domain is not a valid domain! (It was found to be set to ‘’)

I can access Nextcloud AIO Setup via the domain →

As a test, I tried to access my Jellyfin server via my domain with port :8096 (connected in my home network) and stream videos and that went smoothly.

If I change at NoIp from my internal to public Ip I can access to Nextcloud AIO Setup via the domain → and add Then only animation icon rotates in a circle and nothing more happens.

The end-goal would be to get at least Nextcloud server running and accessible outside my home network through “nextcloud.noip.mydomain”. But that doesn’t even work when I’m connected to my home network. I don’t have Pi-Hole yet.

So which of these (sub-)domains do you want to use for Nextcloud in the end? or ?

nextcloud.noip.yourdomain would be better for nextcloud. Sometime later then jellyfin.noip.yourdomain for jellyfin.

If you know what I mean.

I see. Then you need to configure your subdomain and put your public ip-address into the A DNS-record. If your public ip-address changes, I would recommend to use ddclient for automatic updates of the A-record. After it is set up, you should be able to put that into the domain field and proceed.

Alternatively, you could use a cname dns-record for subdomains if ddns should already be set up for one domain…

Basically, that’s how I did it. Instead of DDClient via DynDNS setting in the router.

Now I turned off in the router and tried to do via a DynDNS program (not DDClient because it is only for Unix systems). Marcs DNS Updater it is called.

Subdomains like and I don’t have yet, because I still use the free model of NoIp and want to get it first working with Nextcloud.
Therefore only one domain is applicable and that is

After adding my domain “” still only animation icon rotates in a circle and nothing more happens.

Hi, we made some improvements for the domain validation which hopefully will prevent such freezes in the feature by adding a timeout. Testing and feedback is welcome! See GitHub - nextcloud/all-in-one: Nextcloud AIO stands for Nextcloud All In One and provides easy deployment and maintenance with most features included in this one Nextcloud instance.