Cannot run bigint identifiers command

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 15.0.2
Operating system and version (eg, Ubuntu 17.04): Debian 9 (stretch)
Apache or nginx version (eg, Apache 2.4.25): nginx/1.10.3
PHP version (eg, 7.1): 7.0

The issue you are facing: I cannot run command sudo -u www-data ./occ db:convert-filecache-bigint as mentioned here. It was recommend to take care of this in my admin setting page which provides security checks of the instance.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. connect to console
  2. cd /var/www/nextcloud
  3. sudo -u www-data ./occ db:convert-filecache-bigint

The output of your Nextcloud log in Admin > Logging:

pi@nextcloud:/var/www/nextcloud $ sudo -u www-data ./occ db:convert-filecache-bigint
sudo: ./occ: command not found
pi@nextcloud:/var/www/nextcloud $

Any idea what am I doing wrong?

Kind regards

sudo -u www-data php occ db:convert-filecache-bigint

Hi Himbeere,

I fallowed your recommendation but my output is:
Could not open input file: occ

I have my nextcloud data mounted on an external HDD, is this perhaps a reason for our trouble?

Thank you guys a lot