Cannot quit/delete shared folder from other server

Hello!

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

[/details]

[Nextcloud Hub 8] ) (29.0.2)

Operating system and version Ubuntu 22.04
Apache or nginx version Apache2
PHP version Version : 8.2.20

The issue you are facing:

I was shared folder from other nextcloud server. No icon appreared on the folder after its acceptance. Files and folders are not seen correctly. Finally shared folder from the recepient side cannot be deleted even from the server. I have full permissions. Any ideas how to delete it?

Is this the first time you’ve seen this error? (Y/N):

Steps to replicate it:

  1. I share the folder from one server to another
  2. I accept the invitation
  3. After accepting on the other server there is no icon on the folder and I cannot quit.

The output of your Nextcloud log in Admin > Logging:

PASTE HERE

Error
Undefined array key 1 at /home/Gintcho/web/…/apps/files_sharing/lib/External/Cache.php#41

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

PASTE HERE

The output of your Apache/nginx/system log in /var/log/____:

PASTE HERE

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

PASTE HERE


You can clean up orphaned shares:
https://docs.nextcloud.com/server/latest/admin_manual/configuration_server/occ_command.html#files-sharing

and a bit further down also for Files External, you can list mount points, verify them and delete them.

Does your federated share show up there?


Hello,

These instructions do not work for my case. I tried them. You can see the missing icon on the right side.
Finally can I get rid of this folder?

normally, if you click on the 3 dots, you should see an option leave this share. The missing icon normally shows the user icon from the federated server, perhaps there is a problem in the connection or the icon generation at the other server that is not working properly.

Hi,

I know for “leaving the share” option. In my case it is not present. If I tried to delete the shared forlder but it says the “server is in maintenance”, which is not true at all.

The problem is somewhere else, and I decided to ask for help here…

Any other possible solution for getting rid of this shared folder? It could be a bug.

And you see nothing in the logs? Sounds a bit like the servers perhaps don’t see each other or their communication is (partly) blocked?
The occ commands from the documentation they don’t show anything?