Cannot mount windows share secondary drive

Nextcloud version: 11.0.2
Operating system and version: Debian 8.7
Apache or nginx version: Apache/2.4.10
PHP version: 5.6.30
Is this the first time you’ve seen this error?: yes

I could observe a strange behavior with SMB / CIFS on the external storage app.

We have a Windows 2012 Server which hosts various shares on an ntfs file system. If you create the share on the c: drive of windows there is no problem to connect from nextcloud.
But our fileserver has a secondary harddisk on which the data is stored. In my example its drive d: but i cant mount any shares hosted on this drive. I even copied the share from the c: drive to the d: drive and gave him the same share name and checked the permission. Again could not mount the share.

Later i tried this in my lab with a Windows 2016 Server with the same result. In a next step i mounted the shares direct on the debian system with the smbclient and this worked flawless.

Now to the golden question is this a problem with the smbclient, windows or the nextcloud?

Did someone already had the same problem or can even reproduce it?

I appreciate any help and effort that helps to find the Problem.

Hello Community

The problem with the external storage and Windows still persists.

I build a new test environment:

Nextcloud version: 12
Operating system and version: Debian 9.0
PHP version: 7.0
External Storage Server: Windows 2016

I did the following tests with the smbclient

Path          ShareName Nextcloud Debian smbclient Command
C:\Share\Test1    Test1    OK     OK
D:\Share\Test2    Test2    NOK   OK

So the problem occours only with nextcloud.

I did another test with the PHP-smbclient (libsmbclient) and here the connection works flawless. But the perfomance is pretty bad. We are using a 1Gbit Interface and with the smbclient packet I get about 800-900Mbit. But with the PHP-smbclient it collapse to about 80-100Mbit. I fiddled already with the smb. conf file. But no setting is boosting it to the 1Gbit.

I need a solution otherwise our customer will use a alternative to nextcloud.

Kind of necrobumping, but I ran into the exact same issue with Nextcloud 17, Windows 2012 server secondary drive cannot mount into Nextcloud, but the C: Drive has no issues.

Nextcloud version: 17.0.0
Operating system and version: CentOS 8
PHP version: 7.2
External Storage Server: Windows 2012

In my tests the exact same symptoms as OP, smbclient and libsmbclient both connect, (I did not benchmark in any way). But all shares work perfectly except when connecting from Nextcloud the share just fails. No logs are generated when trying to connect to the share. It just fails with no error messages.

Same problem here.
I’m running Nextcloud 18.0.4 and this occured after I updated Ubuntu 19 to 20 and php 7.3 to 7.4.

Ubuntu 20 & Nextcloud 19 and 20 same Problem.

is there already a solution here?

This is a duplicate post to one I added in the German support forum: Externer Speicher funktioniert auf C: aber nicht auf D: - #76 by ionpcs

Using NC21, I am having the same problem mounting shares that reside on the secondary, non-system, D: drive of my Windows Active Directory DC (Server 2012 r2). The work around of mounting drives on the host solves my problem of making the company wide Shared drive available.

I also need the users to be able to access their home directories. If I mount the Users folder on the host machine, all files and operations made by users in Nextcloud will result in the permissions for the “Windows Nextcloud User” account and not the user’s own permissions. My users folder is on a D: drive on the Windows server. I’m going to try adding E:, F:, G:, etc and see if the issue translates to any drive letter other than C:. I’m about ready to buy some new drives and move everything to the C: drive just so I can get this working sooner than later, but this seems ridiculous. There has to be a way to get this to work with some code changes.

D:\Data\Shared and D:\Data\Users are the folder paths I am trying to share.

Really, I don’t want to use the work around for the Shared drive either because it reduces the auditing that can be done; All NC users actions will be on behalf of the same “nextcloud” user account with which the share is mounted.

If I can be of assistance somehow please let me know. I’m not an advanced programmer.

Problem still exists on NC21

2022 and the error persists, I’m using the following configuration:
Nextcloud version: 23.0.3
Operating system and version: Ubuntu 20.04.3
Apache or nginx version: Apache/2.4.41
PHP version: 7.4.28
mysql: 8.0.28
Is this the first time you’ve seen this error?: yes

We’ve recently bought a new server with windows 2022, and as good practices we have our shares on disk D because the C one is for the OS. It’s weird no one has found a solution after 5 years since the first post, looks like I’m gonna need to find another solution unfortunatelly.