Cannot login from the FQDN

Hi all,
I’ve a very very noob to this system so please be gentle with me 0:-)
I’ve just installed a NCP with the scrip that I’ve found on Proxmox Helper Scripts | Scripts for Streamlining Your Homelab with Proxmox.
Now I’m trying to configure it with my network.
I’ve configured my router in order to reach my NCP server with the FQDN (for the moment no SSL in order to do not complicate more the things).
I’ve also modified the file /var/www/nextcloud/config/config.php => adding

  'trusted_domains' =>
  array (
    0 => 'localhost',
    15 => 'FQDN:port',

when I write in the browse the http://FQDN:port - I get the the login page, but when I enter login/password nothing happens.
If I connect to the local network everything works.

Any ideas on how can I fix it?

thank you to all

When you log in from your LAN, is it by any chance sending you to a different port? Look in the URL bar after you log in.

yes… on internal lan is standard 80 port. from outsite it goes to a different port.
On the router I have a redirection extport=>80

I think maybe this causes some confusion to access it on different ports based on location, and it’s not a good practice anyway. If you can’t or don’t want to use port 80 online, I would change the port on the actual web server and then use that port consistently inside and out.

I wonder if what may be happening is it tries to send you back to port 80 after the login screen. You could fix that by setting overwritehost to include the port, but then it would break LAN access instead.

OK, I will think to use some kind of proxy like ngix and hope to fix the problem. :frowning:
But any kind of other suggestions are welcome :slight_smile: