Cannot install talk on fresh nextcloud 18 install

Nextcloud version:
Operating system and version: Centos 8.1.1911
Apache: Apache/2.4.37 (centos)
PHP version: PHP 7.4.1 (cli)

Hey guys, i get this error when trying to install talk on a fresh nextcloud 18 install:

[PHP] Error: Cannot declare class OCA\Talk\Migration\Version2000Date20170707093535, because the name is already in use at /var/www/html/nextcloud/apps/spreed/lib/Migration/Version2000Date20170707093535.php#31

I’ve done a fresh install 3 times a row and still got the same problem.

I saw on the talk app page that it’s in alpha for nextcloud 18 so maybe it’s a bug linked to this new release?

Anyone know what can i do about that?


1 Like

Anyone please?

Steps to reproduce

Go to app stores and try to install Talk on a fresh install

Expected behaviour

It should install Talk

Actual behaviour

Doesn’t install Talk

Server configuration detail

Operating system: Linux 5.4.0-9-generic #12-Ubuntu SMP Mon Dec 16 22:34:19 UTC 2019 x86_64

Webserver: Apache/2.4.41 (Ubuntu) (apache2handler)

Database: mysql 10.3.21

PHP version:

Modules loaded: Core, date, libxml, openssl, pcre, zlib, filter, hash, Reflection, SPL, sodium, session, standard, apache2handler, mysqlnd, PDO, xml, bcmath, bz2, calendar, ctype, curl, dom, mbstring, fileinfo, ftp, gd, gettext, gmp, iconv, imagick, intl, json, exif, mysqli, pdo_mysql, Phar, posix, readline, shmop, SimpleXML, sockets, sysvmsg, sysvsem, sysvshm, tokenizer, wddx, xmlreader, xmlwriter, xsl, zip, Zend OPcache

Nextcloud version: 18.0.0 -

Updated from an older Nextcloud/ownCloud or fresh install:

Where did you install Nextcloud from: unknown

Signing status


List of activated apps
 - accessibility: 1.4.0
 - activity: 2.11.0
 - analytics: 2.0.0
 - bookmarks: 2.3.4
 - bruteforcesettings: 1.5.0
 - calendar: 2.0.1
 - cloud_federation_api: 1.1.0
 - comments: 1.8.0
 - contacts: 3.1.6
 - dav: 1.14.0
 - deck: 0.8.0
 - documentserver_community: 0.1.2
 - extract: 1.2.3
 - federatedfilesharing: 1.8.0
 - federation: 1.8.0
 - files: 1.13.1
 - files_pdfviewer: 1.7.0
 - files_rightclick: 0.15.2
 - files_sharing: 1.10.1
 - files_trashbin: 1.8.0
 - files_versions: 1.11.0
 - files_videoplayer: 1.7.0
 - firstrunwizard: 2.7.0
 - gpxpod: 4.1.0
 - issuetemplate: 0.6.0
 - keeweb: 0.6.1
 - logreader: 2.3.0
 - lookup_server_connector: 1.6.0
 - mail: 1.0.0
 - nextcloud_announcements: 1.7.0
 - notes: 3.1.1
 - notifications: 2.6.0
 - oauth2: 1.6.0
 - occweb: 0.0.4
 - onlyoffice: 4.1.1
 - password_policy: 1.8.0
 - phonetrack: 0.5.11
 - photos: 1.0.0
 - privacy: 1.2.0
 - provisioning_api: 1.8.0
 - serverinfo: 1.8.0
 - settings: 1.0.0
 - sharebymail: 1.8.0
 - support: 1.1.0
 - survey_client: 1.6.0
 - systemtags: 1.8.0
 - text: 2.0.0
 - theming: 1.9.0
 - twofactor_backupcodes: 1.7.0
 - updatenotification: 1.8.0
 - viewer: 1.2.0
 - workflowengine: 2.0.0
 - admin_audit
 - encryption
 - files_external
 - recommendations
 - spreed
 - user_ldap

Configuration (config/config.php)
    "instanceid": "***REMOVED SENSITIVE VALUE***",
    "passwordsalt": "***REMOVED SENSITIVE VALUE***",
    "secret": "***REMOVED SENSITIVE VALUE***",
    "trusted_domains": [
    "datadirectory": "***REMOVED SENSITIVE VALUE***",
    "dbtype": "mysql",
    "version": "",
    "overwrite.cli.url": "http:\/\/localhost\/nextcloud",
    "dbname": "***REMOVED SENSITIVE VALUE***",
    "dbhost": "***REMOVED SENSITIVE VALUE***",
    "dbport": "",
    "dbtableprefix": "oc_",
    "mysql.utf8mb4": true,
    "dbuser": "***REMOVED SENSITIVE VALUE***",
    "dbpassword": "***REMOVED SENSITIVE VALUE***",
    "installed": true,
    "app_install_overwrite": [

Are you using external storage, if yes which one: n/a

Are you using encryption:

Are you using an external user-backend, if yes which one: n/a

Client configuration

Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:73.0) Gecko/20100101 Firefox/73.0

Operating system: Ubuntu 20.04


Web server error log
[Wed Jan 22 20:40:22.266095 2020] [php7:error] [pid 7824] [client] PHP Fatal error:  Cannot declare class OCA\\Talk\\Migration\\Version2000Date20170707093535, because the name is already in use in /var/www/nextcloud/apps/spreed/lib/Migration/Version2000Date20170707093535.php on line 127
Nextcloud log
Cannot declare class OCA\Talk\Migration\Version2000Date20170707093535, because the name is already in use at /var/www/nextcloud/apps/spreed/lib/Migration/Version2000Date20170707093535.php#127
Browser log


OK… I solved it. For whatever reason. Spreed seems to have been pre-installed but not active. after removing the folder from the app folder and restarting the server, I was able to install talk.


I’ve tried again doing what you did but got the same error.

But after the install error pops up i noticed there was still an “activate” button available.

I just pressed it and it works.

So it’s a non blocking install error i guess!


I had a simulary issue. I tried to reinstall Talk/spreed but faild very often. I want to share my full solution for anyone who stuck in the same situation as I did.

Please be warned that we will drop/delete all the Chats. Make sure to backup your chat’s/Database if you want to.

First I removed spreed:
sudo -u www-data php occ app:remove spreed
Then I cleaned the things in the Datebase (in my case mariadb) Thank goes to j-ed
DROP TABLE IF EXISTS oc_talk_commands; DROP TABLE IF EXISTS oc_talk_guests; DROP TABLE IF EXISTS oc_talk_participants; DROP TABLE IF EXISTS oc_talk_participants_org_20200403; DROP TABLE IF EXISTS oc_talk_rooms; DROP TABLE IF EXISTS oc_talk_signaling; DELETE FROM oc_migrations WHERE app='spreed'; DELETE FROM oc_preferences WHERE appid='spreed';

Then to make sure this error wont happen I executed some mariadb commands too:
set global innodb_large_prefix=on;set global innodb_file_format=Barracuda;

Then I made sure everything is working fine or will get fixed by:
sudo -u www-data php occ maintenance:repair

While installing the app, the error promt out, but I could just enable spreed and it worked again (all Data is gone, of course)
sudo -u www-data php occ app:install spreed
sudo -u www-data php occ app:enable spreed

Same error found here, appeared when installing via console: occ app:install spreed
We need to report this to GitHub if there is no matching issue:
I’ll see if I find time tomorrow.

Issue already reported:
Solved for NC19: