Cannot install richdocumentcode: could not download app


On my nextcloud 18.0.8 I tried to activate CollaboraOnline, and needed a server.
From the https://<hostname>/nextcloud/index.php/settings/admin/richdocuments

I clicked on the Install it from the app store and I landed in https://<hostname>/nextcloud/index.php/settings/apps/app-bundles/richdocumentscode but I could not find where I should click:

I could not find ‘rich’ in the list of bundles/apps.

So I tried the CLI:

/var/www/nextcloud# sudo -u www-data php -d memory_limit=512M occ app:install richdocumentscode
Error: Could not download app richdocumentscode

It’s as if the package didn’t exist. I tried to replace richdocumentscode by foobarbaz123456 and the exact same error message…

Any clue ?

Install the Communty Document Server for Only office or the complete HUB Bundle

but I think you want the Collabora Online build-in Code Server

search coll in the app store and you will find it

Collabora online built on server is not available for nc 18. You need first upgrade your nc to the latest version (19.0.2).
Don’t install only office built in server, there is a major bug

Hum, thanks @bastien , it seems that upgrading to 19.0.2 is THE solution (I now can see the app in the app store).

@Vincent_Stans: the entry was not shown (probably due to wrong versioning).


  • why is the option shown (if it’s not compatible) ?
  • why is the error message not explicit enough (e.g. no download for your version) ?


1 Like