Cannot get Passwords app to work

Hello folks,

This is the first time I post something on this forum.
Have read a lot and did give me solutions for questions I had, thank you for that !

For a year I’m running NC on a PC with VirtualBox.
Running the latest stable version ( 20.0.7 ) with PHP version 7.4.3, all works fine without any issue’s.

Due the change of the free account policy of LastPass, I’m investigating the NC app Passwords.
Have setup the App, imported all my passwords and have the Chrome extension working already.

The problem I have is the NC Passwords Android app.
I can login, but it keeps hanging at the ‘grant access’ button.
I see that the app is connected in the security menu, but nothing happens at the phone side.
The regular NextCloud app is working fine btw.

Searching the web gives me a lot of the same solutions, add to the config.php file:
‘overwrite.cli.url’ => ‘https://urlofnextcloud:443’ (also tried without 443)
‘overwriteprotocol’ => ‘https’
But still no luck.

I’m not using a special portnumber (altough I will change that after I get this working).
I don’t have a any proxy running.
In my firewall logs I don’t see anything that is blocking.

Anyone any idea’s or sugestions?

Kind regards,

Which android app are you using?
This one:
Or this one: ?

Are you using a self signed certificate?

Which version of the passwords app for Nextcloud are you using?

Are there any errors in the nextcloud log?

I doubt that the ‘overwrite.cli.url will help in this case since it is only for the command line. But setting it to the correct url is always helpful.

Version of Android : 11
I use the first App (the second one doesn’t work at all)
Yes, a self signed certificate
Passwords app version : 2021.2.0

The errors I have in the log, but that is from the Chrome extension:

Maybe @joleaf knows better, but i think self signed certificates are not (yet) supported. That’s what is written in the app description.

I missed that, feeling stupid :roll_eyes:

The other app is also not working, giving the error: ‘Network Error’ while the NexCloud app itself (filesharing) is working like a charm.

Likely for the same reason: see the app description:

Important note: this application doesn’t work with self-signed certificates. You have to install a free LetsEncrypt certicate for example on your Nextcloud.

Ok, I’ll try that instead, thanx

Can confirm that using a LetsEncrypt certificate does work, can connect with the app now.

Thanx for your input mdw !

Indeed, self-signed certificates don’t work for now.
I’m currently working on that issue (see Feature-Request: Self-Signed Cert (#41) · Issues · Jonas Blatt / NC Passwords Mobile App · GitLab).

I am having a similar problem. I am using the first app (NC Passwords), I have LetsEncrypt working for my https certificates and have not done self-signed at all. But as the OP said, I get stuck at “Grant”, and the app simply will not finish.

Not sure if there is another place I need to set up certs inside NextCloud, haven’t had much of an opportunity to fully investigate, but I am hoping maybe someone can point me in the right direction. Thanks.

I am using the Ubuntu Core/snap installation of NextCloud, on a Raspberry Pi 4b.

I used this guide to get it working:
Started at the headline : “Secure NextCloud with Let’s Encrypt Free SSL”

1 Like

I looked at that. I already have LetsEncrypt set up and working for my domain. I have it behind an NGINX reverse proxy, where the LetsEncrypt certs all live, and that reverse proxy connects to my nextcloud snap device (over http on my LAN).

I am still getting stuck, and honestly am not sure where to start looking. Deploying the LetsEncrypt certs on my device doesn’t seem to be all that beneficial as it is a snap-based nextcloud appliance, and isn’t directly connected/reachable from the internet, except through my NGINX reverse-proxy.

I’ve read a lot before it getting to work.
I came across many of the same solutions (especially behind a proxy), they all advise to add this to the config.php file (which I did):

‘overwrite.cli.url’ => ‘https://urlofnextcloud:443’ (also tried without 443)
‘overwriteprotocol’ => ‘https’

1 Like

I did that as well. And… it isn’t working. I can’t get past Grant.

Same issue here. I have a valid certificate and the Android Apps Talk, Notes and Deck make use of it with a dedicated password each.

I can not get NC Password to work and I think one can fairly conclude it as an NC Password App-specific issue.

Same problem here. haproxy with letsencrypt which forwards http to https. Can not login with app password - hangs on “Grant”. Using TOTP two factor on my system. Without TOTP enabled it worked. This sucks. Argh.
When I use the QR-Code login it works. Something’s not handled very well within the app.

In my case it was my mistake as I did mix the two existing Nextcloud Apps Passman and Password.
Passman unfortunately appears as Passwords in the top menu bar.
I downloaded Passwords App for Android then and this did not work of course.
There is a Passman Android App as well and it worked instantly with it.