Cannot get Nextcloud to install on Asustor

Morning Everyone,

I have an Asustor Lockerstor As6604T running ADM 4.0.2.RPL2, and I am trying to install Nextcloud 22.1.1.r01 onto it. I just download the package from the Asustor app store.

I followed the directions on the web exactly. I had created an admin account, and could log in to Nextcloud. However, when I got to the point in the tutorial where it says to click ā€œStorage and Databaseā€, I could not get back to that screen. I read online that I could just add the information manually in the config.php file, so that is what I tried to do. I say tried, because what I actually did was delete the file by accidentā€¦

Since this is a new install and thereā€™s no data to lose, I figured I would just uninstall and reinstall the program. However, when I do this a) No config file shows up in the config folder and b) I can no longer reach the web GUI. I just get an error that says ā€œERROR_CONNECTION_REFUSEDā€ and thatā€™s it. All of my ports are forwarded correctly, and there has been no change in anything else. MariaDB and phpMyAdmin are still correctly configured as well.

I am not sure why after creating an admin account and logging in, there is no way that I can tell to go back to that same installation screen again to click on the database option? I am also not sure what I have to do to wipe this from my server so I can hopefully start again.

Any help is appreciated!
Thank You.

You can try to find the config.php on your system. But we didnā€™t do the packaging, so no idea if that is in a container, virtual machine or just in some folder. The connection refused could indicate that some service did not start or crashed. If you have access to logfiles, you might get more information which part is not working.

They have a developer center: https://developer.asustor.com/
there is a login, perhaps you find useful stuff there. Or this forum:
https://forum.asustor.com/