Cannot get Nextcloud Office to work

This is one of the most frustrating things I’ve tried to deal with in a LONG time.

I simply cannot get Collibra working, either the internal one, nor an external one running in docker.

I have looked all over the internet but have failed to find any simple details of how to get this working.

I’m using the snap version of Nextcloud and when I select the internal version, I get a green tick (most of the time) but when I try and open doc or xls files they simply download.

I installed Collabora in a docker container on the same machine, in a bridge network, and can get a green tick with the IP address and port entered in the settings, but when I try and open a doc I get an error saying unable to start Nextcloud office.

I finally tracked down some logs for the snap and can see this error

{“reqId”:“vT4OFw1fWmIwPYXYnWpy”,“level”:2,“time”:“2022-03-18T08:10:11+00:00”,“remoteAddr”:“192.168.44.134”,“user”:“pnunn”,“app”:“no app in context”,“method”:“GET”,“url”:"/index.php/core/preview?fileId=1988&x=32&y=32",“message”:“Host 172.17.0.3 was not connected to because it violates local access rules”,“userAgent”:“Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/98.0.4758.109 Safari/537.36 OPR/84.0.4316.42”,“version”:“23.0.2.1”}

which sort of makes sense as the 172 network is the docker bridge network and I havn’t configured that anywhere else in the system.

Does anyone have any tutorials on how to get this working with the snap version of nextcloud?

System config file attached (or would be if I could upload that type of file)…

## Server configuration detail

**Operating system:** Linux 5.4.0-104-generic #118-Ubuntu SMP Wed Mar 2 19:02:41 UTC 2022 x86_64

**Webserver:** Apache (fpm-fcgi)

**Database:** mysql 8.0.28

**PHP version:** 8.0.16

Modules loaded: Core, date, libxml, openssl, pcre, zlib, bcmath, bz2, ctype, curl, dom, hash, fileinfo, filter, ftp, gd, gmp, SPL, iconv, intl, json, ldap, mbstring, pcntl, PDO, session, posix, Reflection, standard, SimpleXML, mysqlnd, exif, tokenizer, xml, xmlreader, xmlwriter, zip, pdo_mysql, cgi-fcgi, redis, Zend OPcache

**Nextcloud version:** 23.0.2 - 23.0.2.1

**Updated from an older Nextcloud/ownCloud or fresh install:** 

**Where did you install Nextcloud from:** unknown

<details><summary>Signing status</summary>

Array
(
)

</details>

<details><summary>List of activated apps</summary>

Enabled:

  • accessibility: 1.9.0
  • activity: 2.15.0
  • calendar: 3.2.1
  • circles: 23.0.1
  • cloud_federation_api: 1.6.0
  • comments: 1.13.0
  • contacts: 4.0.8
  • contactsinteraction: 1.4.0
  • dashboard: 7.3.0
  • dav: 1.21.0
  • deck: 1.6.1
  • federatedfilesharing: 1.13.0
  • federation: 1.13.0
  • files: 1.18.0
  • files_pdfviewer: 2.4.0
  • files_rightclick: 1.2.0
  • files_sharing: 1.15.0
  • files_trashbin: 1.13.0
  • files_versions: 1.16.0
  • files_videoplayer: 1.12.0
  • firstrunwizard: 2.12.0
  • logreader: 2.8.0
  • lookup_server_connector: 1.11.0
  • nextcloud_announcements: 1.12.0
  • notifications: 2.11.1
  • oauth2: 1.11.0
  • password_policy: 1.13.0
  • photos: 1.5.0
  • privacy: 1.7.0
  • provisioning_api: 1.13.0
  • recommendations: 1.2.0
  • richdocuments: 5.0.3
  • richdocumentscode: 21.11.204
  • serverinfo: 1.13.0
  • settings: 1.5.0
  • sharebymail: 1.13.0
  • spreed: 13.0.3
  • support: 1.6.0
  • survey_client: 1.11.0
  • systemtags: 1.13.0
  • text: 3.4.0
  • twofactor_backupcodes: 1.12.0
  • user_status: 1.3.1
  • viewer: 1.7.0
  • weather_status: 1.3.0
  • workflowengine: 2.5.0
    Disabled:
  • admin_audit
  • encryption
  • files_external
  • theming: 1.13.0
  • user_ldap
</details>

<details><summary>Configuration (config/config.php)</summary>

{
“apps_paths”: [
{
“path”: “/snap/nextcloud/current/htdocs/apps”,
“url”: “/apps”,
“writable”: false
},
{
“path”: “/var/snap/nextcloud/current/nextcloud/extra-apps”,
“url”: “/extra-apps”,
“writable”: true
}
],
“supportedDatabases”: [
“mysql”
],
“memcache.locking”: “\OC\Memcache\Redis”,
“memcache.local”: “\OC\Memcache\Redis”,
“redis”: {
“host”: “REMOVED SENSITIVE VALUE”,
“port”: 0
},
“log_type”: “file”,
“logfile”: “/var/snap/nextcloud/current/logs/nextcloud.log”,
“logfilemode”: 416,
“passwordsalt”: “REMOVED SENSITIVE VALUE”,
“secret”: “REMOVED SENSITIVE VALUE”,
“trusted_domains”: {
“0”: “localhost”,
“1”: “192.168.44.165”,
“3”: “nextcloud.marketdispatch.com.au”
},
“datadirectory”: “REMOVED SENSITIVE VALUE”,
“dbtype”: “mysql”,
“version”: “23.0.2.1”,
“overwrite.cli.url”: “http://localhost”,
“dbname”: “REMOVED SENSITIVE VALUE”,
“dbhost”: “REMOVED SENSITIVE VALUE”,
“dbport”: “”,
“dbtableprefix”: “oc_”,
“mysql.utf8mb4”: true,
“dbuser”: “REMOVED SENSITIVE VALUE”,
“dbpassword”: “REMOVED SENSITIVE VALUE”,
“installed”: true,
“instanceid”: “REMOVED SENSITIVE VALUE”,
“maintenance”: false,
“mail_domain”: “REMOVED SENSITIVE VALUE”,
“mail_from_address”: “REMOVED SENSITIVE VALUE”,
“mail_smtpmode”: “smtp”,
“mail_sendmailmode”: “smtp”,
“loglevel”: 2,
“theme”: “”
}

</details>

**Cron Configuration:** Array
(
    [backgroundjobs_mode] => cron
    [lastcron] => 1647591170
)


**External storages:** files_external is disabled

**Encryption:** no

**User-backends:** 
 * OC\User\Database


**Talk configuration:** 

STUN servers
 * no custom server configured

TURN servers
 * no custom server configured

Signaling servers (mode: internal):
 * no custom server configured


**Browser:** Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/98.0.4758.109 Safari/537.36 OPR/84.0.4316.42

Thanks.

does this help at all?

thanks @crobarcro unfortunately no.

I can’t find any config for any sort of office in the config.php file. I ran the nextcloud.occ command and added the field as suggested, but that didn’t work either.

What has changed though is that I no longer get ANY errors in the log file, but the document still won’t open.

hmm… I have the exact same problem… a few days ago it worked perfectly… tried to add also the ‘allow_local_remote_servers’ => true, but didn’t help…