Cannot find QRCode for setting up mobile clients

I’ve found this: https://github.com/nextcloud/server/issues/429 and this https://github.com/nextcloud/android/pull/3383 and it looks like the mobile app has QRCode scanner built in for easier client setup, but I cannot find where in my Nextcloud server are those QRCode for client setup… I’m using Nextcloud 15.0.4. When i create new app password/token i still have it in text form and there is no QRCode to scan…

Should I enable something or what ? Cause I cannot find anything about this in the documentation… or even what text should this QRCode contain…

2 Likes

Unfortunately you haven’t fully read the mentioned issue tickets. The function requires
a server part to be integrated which has been scheduled for Nextcloud v16 :wink:

3 Likes

NC16 has been out for a while now. Are there any instructions for using the QR? I cannot figure it out :frowning:

settings -> user security -> generate new password

grafik

the text “QR-Code für mobile Apps anzeigen” is a link. click it.

6 Likes

Sorry for my english, im french :smile:
Hi, i have my QR code, but when i can use android app, i scan and i view https://selynes.com/nextcloud, its ok, but tap enter = test of connexion and nothing… i have test whitout QR code, i have write adress but its same…

and the adress is in https://

thank

In Nextcloud version 19.0.3, in order to generate a QR code to quickly log into your Nextcloud server without entering URL, username or password, take the following steps:

  • go to https://nextcloud.yourdomain.com/settings/user/security
  • scroll down to the bottom of the page
  • click the “App name” field and enter a name that your mobile client app will show up as in your “Devices & Sessions” list (just above)
  • click the “Create new app password” button
    Cattura
    A QR code will then be generated.
  • go to your mobile app, tap the QR icon and scan the QR code. Done.

what has failed to mention is the “Create new app password” button is only available to the logged in account.

If you are an administrator and Impersonate a user, this button is not available to you.

is it a bug or a feature? :wink:

Doesn’t seem to exist for LDAP accounts, either.