Cannot delete multiple files

Nextcloud version: Nextcloud Hub 5 27.0.2
Operating system and version: Debian 12 + docker
I am using NextCloud AIO

The issue you are facing:

I cannot really use NextCloud properly. So many people like it, but it doesn’t work for me well.

  1. Creating a file results in “Unable to create new file from template” + "Could not fetch file details “”. After page refresh, the file is actually there.

  2. Removing files with checkboxes + actions menu doesn’t work at all. There is zero reaction and zero information in the logs. The files just stay.

  3. If I use 3 dot menu on single file (no selection), the progress indicator is shown on file and spins indefinitely. After refreshing the page, the file is indeed deleted.

  4. If I select all files in directory, I can download them with actions menu, but if I deselect at least one, nothing happens.

The output of your Nextcloud log in Admin > Logging:
Nothing related I guess. It pops up much more rarely than my attempts to delete files

proc_open(): Exec failed: No such file or directory at /var/www/html/custom_apps/memories/lib/Exif.php#355

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

not sure how to find it

I run it in Debian VM under proxmox. I have Intel i5-10400, 32GB ram assigned to this VM. I have storage on NVME with 400 GB free space.

I disabled most of the apps, I setup onlyoffice, but it actually doesn’t matter. Initial setup is as broken as current.

When I am googling my issues I find nothing. I have no idea how to debug and fix it. I’d really love to have nextcloud working properly :confused:

Please post your Docker Compose file along with the output from occ config:list system and occ config app:list.

The "Could not fetch file details “” is the result of a WebDAV query so the server-side logs should show something that matches the transaction if they’re configured reasonably.

Given the other issues noted, can you:

  • try from a different browser
  • clarify whether you’re using a proxy/CF/etc?

Also may be worth disabling the memories app to re-test without it.

1 Like

Thank you so much!!

The logs that I see in the UI literally have nothing pipping up after the error with I have default config from AIO

I tried a different browser: switched from Opera to Chrome and it worked there. No errors at all and everything is fast and correct. Then I used private mode in opera and it also works. I disabled adblocking and all extensions and it is still broken in my Opera but I guess this is fixable somehow.

Thank you again. I wouldn’t think about such a simple thing!

1 Like

Glad to hear you made some progress!

Are there any clues in the browser console, in the Network tab and the JS console, maybe?

Oh, that is a good lead. I get this:

delete selected:
It gives _.pluck is not a function.
just delete:

It looks like lodash is missing. But when loading the page, I see no error requests in the Network tab.

Creating a file also has an error with _.findWhere.

I also checked creating file in incognito mode, where it works without any issues (files is created, changes are saved, no errors in UI), but it shows these errors in the console:

I run my nextcloud behind Caddy: {
	tls {
		dns cloudflare <REDACTED>

I have a valid domain, but I run it in tailscale, so it is not available from outside.