Cannot create calendar entry

I’m new to this forum but not new to Nextcloud. I’ve been using it on a home server but decided to install an instance on a shared web host so that I can more easily share calendars without being on our home network. I’ve tried installing with Cpanel and without but get the same result. I install the Calendar app but cannot create an event. The event window opens and I can fill in the details but when I try to save it I just get a spinning cursor and the event never shows up.
Looking for some direction to correct this.

As usual and recommended several times in this forum, check-out the Nextcloud log file for related messages to this problem.

The logging menu item when logged in as admin shows an error of Module ‘sqlite3’ already loaded at Unknown#0. I turned off sqlite in the PHP options and that error goes away. Calendar events still cannot be created and no error appears in the log. Is there another log I should be looking at?

I would recommend to enable the debug logging to get more detailed information about what the Nextcloud server is doing, as described here. Additionally you should read the troubleshooting guide, which you find here.

Thank you. I set the log to debug. Anytime you try to create a calendar entry 7 identical error messages show up.
{“reqId”:“Xwyvvm-zssG9-CShjki@ugAAALo”,“level”:1,“time”:“2020-07-13T19:02:23+00:00”,“remoteAddr”:“98.11.155.132”,“user”:“admin”,“app”:“no app in context”,“method”:“GET”,“url”:"/index.php/apps/files/",“message”:“Deprecated event type for OCA\Files::loadAdditionalScripts: Symfony\Component\EventDispatcher\GenericEvent”,“userAgent”:“Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.149 Safari/537.36”,“version”:“19.0.0.12”,“id”:“5f0cb18980d5a”}

Can you open your browser’s developer tools (F12) and post the content that may appear in the console when you try to create an event.
You may also have a look at what’s happening in the Network panel as well.

Two errors appear and seem to deal with the files folder. Permissions seem correct on the folder.

request.js:339 PUT https://cal.civittolo.net/index.php/apps/files/ 403
and then

vue.runtime.esm.js:1888 Error
at XMLHttpRequest.n.value.regeneratorRuntime.mark.regeneratorRuntime.wrap.e.abrupt.s.onreadystatechange (request.js:353)

So I’m guessing you can’t upload/sync/edit files in the files app as well?

Correct. Upload fails. I also have tons of messages, “The global jQuery is deprecated”

In that case you have setup issues. Check the rights and owner for Nextcloud’s data directory.

Thanks for your help. I’ve tried installing it with the softaculous installer, from scratch, using a setup script that I came across and even tried version 18. Using softaculous the data folder gets put outside the nextcloud root folder but i’ve also tried it in the root folder. I’ve even tried setting the data folder to 777 for permissions. Permissions match a local install so I’m stuck. Might have to find a different application.

I checked with my hosting provider and the answer they gave me was that cloud based scripts do not typically work on shared hosting. Are other people using Nextcloud on a shared hosting provider?

Please use the search function of the forum to find an answer. Many users are using Nextcloud in a shared environment and are struggling to get it running at first. Some succeed, others not.

1 Like

even better: you might need to find yourself a better hoster :wink: