Cannot connect with the Android app when 2FA is enabled


I’m just starting out with Nextcloud. It’s up and running fine, but I’m having an issue with the Android app when 2fa is enabled on the server. The app just says wrong username or password and goes no further. When I disable 2FA, the app connects fine. Also, I can login using the web interface when 2FA is enabled.

The Windows desktop app also fails to connect when 2FA is enabled but works when 2FA is disabled. I this behaviour expected or is something amiss?

Thanks, Rob.

This is a wanted behavior, for the webinterface you use your normal login credentials + 2FA. For sync-processes, you have to create separate passwords. On your personal page you’ll find “App passwords” where you can create username+password for apps.

1 Like

Thank you for your reply. I have created an app password for my Android phone and my Windows 10 desktop app, and can now connect both to the server with 2FA enabled.
One thing I’m unsure of though is whether passwords created like this are only usable on one app or can be shared between apps. I suppose the best way to find out is to try it.:slight_smile:

Thank you again.


You can probably use them on different device. However, why not create for each device its own password. If a device is lost or not trustworthy, you can just kill this one access.

1 Like

Works perfectly with 11.1 and the latest Android app from the store.
Gen an App password in the web view. Brilliant set up :+1:

1 Like