Cannot access NextCloudPi Admin panel

Every time I visit the admin panel website (https://nextcloudpi.local:4443/), I receive the error

403 Forbidden: Forbidden

You don’t have permission to access this resource.

I can use the NextCloudPi device just fine otherwise. I do not have https configured on my local network, so I just add a security exception in Firefox for the website.

I also don’t have ssh enabled on the device, so webpage is the only way I can configure the device unless I hook up a screen and keyboard.

Thanks.

If anyone can give me some pointers on how to start troubleshooting this, I’d be very grateful.

You can only access ncp-web on 4443 from the local network

Thanks for this. I think I am using the same network – The Pi is plugged into the router with an ethernet cord, and I’m using my other devices on wifi from the same router.

yeah if it’s .local then it’s local :wink:

what is your local IP address you are trying to access from (you can leave the last part out)

I don’t quite understand the question. The address of my computer is 192.168.0.114. The Pi is hooked in with a ethernet wire, and the website https://nextcloudpi.local works fine, but navigating to a port 4443 results in the above error.

From Nextcloud Administration>Settings>System check its IP address.

Thanks for that explanation. Currently the NCP IP address is 192.168.1.130, and my (e.g) desktop computer address is 192.168.0.114

Try accessing ncp-web thru https://192.168.1.130:4443

When I visit that address the connection times out.

For a different reason, I needed to replace my TP-link router with a new TP-link mesh network. I just plugged in the Nextcloud Pi to the new network and it worked without any configuration. I can also visit the admin page now. Not sure why things did not work on the old router, but it may not have been an issue with nextcloudpi.

1 Like