Can’t open nextcloud folders in iOS files app, unless I first open it in the Nexcloud app and wait for ALL thumbnails to generate


Nextcloud version: 21.0.0
Operating system and version: Unraid 6.10.0rc2 Docker 20.10.9
Apache or nginx version: NGINX Proxy Manager 2.9.12 (if there is another inside the container, then i do not know that version. Here is the image I’m using)
PHP version: 7.4.25

The issue you are facing: I am trying to use the Nextcloud Files app integration on my iPhone and iPad (Both iOS 15.1), mostly for photography work. The issue is that when using the iOS Files app most folders in my nextcloud, especially larger ones, will not open. I just get an error in the Files app that says;

Content Unavailable
The folder contents could not be displayed because of an unknown error.

The only way I have found to get the folder to open is to first go into the Nextcloud app, open the folder I need and wait for all of the thumbnails to generate (which can take a few minutes). Then I can go back to the files app and the folder will open correctly.

Is this the first time you’ve seen this error? This is the first time I’ve ever tried.

Steps to replicate it:

  1. Try to open large folder in Nextcloud from the iOS Files app
  2. Get Error Message.
  3. Open Nextcloud app, open same folder.
  4. Try again in Files app and I still get the error.
  5. Open Nextcloud app, open same folder, let thumbnails populate.
  6. Try again in files app.
  7. Now works just fine.

Since no one has replied it’s worth mentioning that current build and latest iOS this still happens to me and it’s not just you.

This is for folders containing about 40 images.

Once folder has about 60 images, even opening the folder in NC app first doesn’t help. It will never open.

Tested and repliacted on iPhone and iPad pro.

Nextcloud 24.0.7, Nextcloud app for iOS 4.5.4
iPadPro 6th generation, iPadOS 6.1

The same with me but as for now I have that situation with exactly one folder that does not show any content in ios files app (nextcloud integration). Within nextcloud app everything is fine but the ios files app produces only the error message
Content unavailable

Repeat (Link, that does not change anything)

In german:
Inhalt nicht verfügbar
Der Ordnerinhalt konnte aufgrund eines unbekannten Fehlers nicht angezeigt werden.

I have to say that I use advanced permissions but as said, the content is shown in the nextcloud app but not in the files app (same user).

Any help much appreciated!

Looking in the log of the nextcloud app I found the following info:

2022-11-05 20:54:17 Network request started: GET
2022-11-05 20:54:17 Network request started: No request created yet.
2022-11-05 20:54:17 Network response request:, result: failure(Alamofire.AFError.responseValidationFailed(reason: Alamofire.AFError.ResponseValidationFailureReason.unacceptableStatusCode(code: 404)))
2022-11-05 20:54:17 Network response request:, result: success(138 bytes)
2022-11-05 20:54:17 Network response request:, result: success(221 bytes)
2022-11-05 20:54:17 Network response request:, result: success(270 bytes)
2022-11-05 20:54:17 Network response request:, result: success(100 bytes)