Can’t connect windows app

Hi all,

So I used to have the windows app installed any working fine on windows 7 but recently upgraded to windows 10 and now I get an err insecure response when it attempts to connect.

I can login from chrome browser fine.

I also set my default browser to Microsoft edge and I still get the problem

any suggestions? :slight_smile:



Do you use a self-signed SSL certificate for HTTPS?
Is your server reachable from the outside world and has a full-qualified DNS name?
I try to figure out if this error message is caused by your SSL cert being “not trustworthy”.

If you have SSL cert from a CA and it’s issued for a domain you own, then you could try to enter your full-qualified domain name as server address in the app.

thanks for the reply.

it’s hosted on my local network and i’m trying to access it from my local network using the latest windows app.

once i enter the ip address into the app it says would you like to trust this host. after clicking yes the app opens this popup browser and i get that error.

next cloud is running https as default and it isn’t signed.

worked ok on windows 7 but since doing a fresh windows 10 install i can’t connect.

works ok via the browser

Strange that it worked on Windows 7 and stopped working on Windows 10. Sounds like some OS related issue.
What I’m wondering about, on the other hand, is the URL in your error message. Why “/login/flow”?
Is there really something behind that URL and does ist work in the browser as well?
What server address did you actually enter in the app?

You say that the app asks ‘would you like to trust this host’. I thought this ony happens when the host sends a certificate but you also say ‘next cloud is running https as default and it isn’t signed’. So do you use a host certificate or not?

In case you do use a server certificate: the webview that gives you the error ‘This site cannot be reached’ must also accept this certificate. This does not seem to work and there are several issues reported (see github). There is also a PR that might fix it.

Hello, could you please give a pointer to the issues/PR? a search for ‘cant connect’ only gave #958 #426 #204, which do not seem to apply. Thanks!
I have a self signed cert, I can reach my NC via the browser, but my windows 10 app issue is almost the same, except the 403 page does not have /login/flow in the url, just the 192.168… ip

I was refering to pull-request #630. But this was some time ago and I dont know what has changed in the desktop client since then.