Can only edit files in Nextcloud with Only Office app on Android


I found that Nextcloud works fine with Onlyoffice on my phone and I can edit and save files perfectly now, but I would prefer Collabora as an editor.

Is there a way to do this? I can’t seem to install collabora on my nextcloud server as it’s not self-hosted but maybe I’m missing something.

I don’t really get the question - you can install OnlyOffice but can not install Collabora? or did you use mobile app to edit the files on the phone?

Um, im not the original poster, but yes, thats exactly what i did–ie, on my free Nextcloud account for Android, Collabora was too slow, so i edited my shared docx document using another word processor (WPS Office for Android), which seemed to work fine on the free Nextcloud setup (ie, i could still use Collabora to edit the shared docx document).

Then i paid to upgrade from a shared server recomended by Nextcloud to a dedicated server for Nextcloud sharing, and also a dedicated server for Collabora, both dedicated servers from the same host that provided my free account.

Now, on the paid account, Collabora cant open the docx document like it could before.

The paid Collabora can open a doc version of my docx document, so im not blaming Collabora.

Any suggestions on how to modify my docx document to work with the paid Collabora? I tried converting the docx file to odt, and then back to docx format, but that didnt work.

In my self-hosted instance I can edit .docx documents using Collabora

I think you better ask your hoster. Paid accounts should be backed by proper support…

Well thanks for that reply, Willi Weikum.

I don think Collabora is very phablet friendly, and paying for a dedicated Collabora server didnt make it any more phablet friendly. In my case, i tried to increase the length of the document pages beyond 17 inches. Collabora couldnt handle that and wouldnt load my docx type document.

Collabora really needs a mobile view that can maintain displayed text size when a phablet orientation changes.

Or maybe i need to upgrade my Collabora version.