Can not connect to server: Unknown error occurred!

Hi,

when I try to add my nextcloud account to the android app, I get the error “Unknown error occurred!”.

It looks the same as in Android app, unkown error occured when adding account (non-admin)

On the Server runs nextcloud 12.0.6.1. It was original an owncloud instance that was migrated to nextcloud.

I get the error on two different andoid devices with Version 3.03 and the Development Version 20180419.

In the nginx access log I get only the following message:

X.X.X.X - - [23/Apr/2018:08:27:56 +0200] “cloud.oshahn.de” “GET /status.php HTTP/1.1” 200 157 “-” “Mozilla/5.0 (Android) ownCloud-android/3.0.3”

respectively

X.X.X.X - - [23/Apr/2018:08:28:09 +0200] “cloud.oshahn.de” “GET /status.php HTTP/1.1” 200 157 “-” “Mozilla/5.0 (Android) ownCloud-android/20180419”

The desktop Client runs without any problem. I can connect to the server with other apps like DAVdroid or Nextcloud News.

Can you give me a tip what I can try to solve this? Do you need any other information from me?

Thanks
Oskar

Hi,
Unfortunately I am experiencing a similar issue on a new nexcloud installation with the latest Android app (tested beta as well) on 2 different Android devices. IOS App is working.

Error message is (mixed DE/EN): “Zugriff fehlgeschlagen: Local file does not exist”

BR,
Alex

cc @tobiasKaminsky @mario looking at the user agent strings this should imho work…

@ostcar @minus14 is 12.0.6.1 the latest patch release for Nextcloud 12? Just asking since I am running 13.0.1 without any issues regarding the Android client.

I think 12.0.6.1 is the past release. But I don’t see any official page to support this statement.

But I think it has to be an issue in the andoid app. Thins there is only one (successfull) request to the server. Is there any way to get more informations out of the app? I don’t get to the settings-menu, so I can not activate the development log.

Sorry I did not consider @ostcar’s mention about the server version. I am quite new to nextcloud. I am running server version 13.0.1 and facing this Andoid app issue.

Should I better open a separate thread?

BR,
Alex

@minus14 no separate thread needed

@minus14 @ostcar to get to the root cause of this it is best to open an issue on the development tracker: https://github.com/nextcloud/android/issues

Ok. I opened the ticket here.

1 Like

Thanks @ostcar! Highly appreciate it!

Ok. I solved it. I use nginx as web-server. I head wrong white-spaces in a http-header. After I fixed this, the issue was gone.

@minus14 any news on your side regarding server connectivity? 13.0.1 should just work fine if not like mentioned it is usually a server configuration issue.

Meanwhile I tried to use php5.6 instead of 7.1 becaus I read there might be some issues with sabre dav in combination with php7.

Unfortunately error stays the same:
“Sabre\DAV\Exception\NotAuthenticated: No ‘Authorization: Basic’ header found. Either the client didn’t send one, or the server is misconfigured, No ‘Authorization: Bearer’ header found. Either the client didn’t send one, or the server is mis-configured”

server:

  • lighttpd webserver
  • php 5.6
  • nexcloud server version 13.0.1

[internal function] Sabre\DAV\Auth\Plugin->beforeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))
/srv/htdocs/3rdparty/sabre/event/lib/EventEmitterTrait.php - line 105: call_user_func_array(Array, Array)
/srv/htdocs/3rdparty/sabre/dav/lib/DAV/Server.php - line 466: Sabre\Event\EventEmitter->emit(‘beforeMethod’, Array)
/srv/htdocs/3rdparty/sabre/dav/lib/DAV/Server.php - line 254: Sabre\DAV\Server->invokeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))
/srv/htdocs/apps/dav/appinfo/v1/webdav.php - line 80: Sabre\DAV\Server->exec()
/srv/htdocs/remote.php - line 164: require_once(’/srv/…’)
{main}

@MorrisJobke @JasonBayton any ideas? Afaik 13.0.1 need php7 (right?)

1 Like

5.6 to 7.1 works - see https://docs.nextcloud.com/server/13/admin_manual/installation/system_requirements.html

Beside that it would be good to not use lighttpd - it caused a lot of trouble in the past especially with *DAV. See http://sabre.io/dav/webservers/ for more info.

1 Like

@MorrisJobke @Andy Thank you guys. Your help is much appreciated!
I’ll set up an Nginx and give feedback as soon as available.

Best regards,
Alex

2 Likes

Hi folks,

finally, I got nexcloud13 server running under nginx. And - most important - Android App can connect :slight_smile:

The app is really great- as far as I could see/experience so far.

IMHO nginx configuration is quite a brainf… ehemm challanging :wink: - compared to lighttpd.

Anyway - from my point of view - issue can be closed. Thanks again!

Best regards,
Alex

1 Like