Can not access ISP router to forward port for nextcloud

Installed and running Nextcloud in freenas 11.3 u4 within Lan. But problem is my isp not letting me enter into router. So, Can not forward port and configure dyndns in it. Please, help how can I access my freenas data from internet. Is there any other way out. help help help please.

perhaps you have ipv6 and you can configure the firewall to pass packages. Means you need mobile connection that has ipv6 as well.
If you can’t change the port forwarding on ipv4, you probably have carrier grade NAT. There is not really much you can do, there are only dirty solution, tunnel through a VPN or something similar. So finally, you can directly get a virtual server …

I’ve just managed to install n run nextcloud in freenas. can you point me to some good vpn solution. I’m kind of lost. What I really want is, to have access to my data from my home.

Hi @Sam_Shrestha,

Have you considered ngrok?

The free tier should be more than adequate.

I use it personally to administer my boats motioneyeos CCTV system than runs over mobileBB with the providers CGNat. Was a real pain until is was pointed to Ngrok.

I did write a script that starts the tunnel, emails the tunnel url to me and also sends me a notification using pushsafer to my mobile with the tunnel url.

In the paid plans you can specify a subdomain and as you’d expect do a little more and you pay more.

1 Like

Thnak YOu NeptuneUK… I’ll Study it… Thank you bro…

Do you have an own ipv4 address.

Here is your external ip address:

Look on your router if it matches.
Post details. You can anonymize the last number a.b.c.d with a.b.c.***

I’m just studying about ngrok… but did not found any reference how to install it in freenas.

my ISP does not let me login to my router… that is why I need a way other than port forwarding and dynamic dns… I think ngrok is good… but I am totally lost how to install and configure it in freenas… because all the tutorial is for linux and windows… I need to find a way to install ngrok in freenas and make tunnel as http server or ftp so that I can download and upload files to freenas dataset.

I have installed the ngrok in freenas through shell. the commands are :’

1. unzip /path/to/
2. ./ngrok authtoken 1gXMf1jCPImn63vuyi7GU2IZc27_2yAHJvK6qLND6JPL8nRbu

now in the tutorial To start a HTTP tunnel forwarding to your local port 80, run this next:

./ngrok http 80

which port to forward for nextcloud??
please help.. and after forwarding Should I use ngrok for windows 10 in client PC to access files?? Plz, help

Change your provider.

Hi @Sam_Shrestha,

Create the Ngrok tunnel to the port on which you have NC listening (80 / 443 or whatever you have configured). e.g for NC listening on http port 443 via a tunnel created in the EU region
ngrok http --region=eu 443

Please re-read the docs. Every question will be answered in them.

In effect a tunnel to your NC instance that you can access from any location external to your network. The address will be something like (remember that you can specify a region as demonstrated above - all of this is in the documentation, as is information on how to add basic auth security to your tunnel.)

To access you NC instance from the same local network, just address it as you would do normally. Either via it’s local network ip or hostname.

Please remember on the free plan tunnels are temporary, refer to my original post about what you may want to do about that by writing a bash script to handle when it changes or pay for an upgrade to access a stable tunnel. There are other solutions such as openvpn but I suspect for you the Ngrok option is:

When you create a tunnel you will see the tunnel endpoint displayed, this is the url to use to your tunnel. You can also see the current tunnel process addresses in your Ngrok account.


I started the ngrok but when I open the url it opens Freenas webUI login page.

I don’t know what is wrong

You must have set the wrong port in ngrok. On what port is running Nextcloud ? The Freenas webUI probably runs on port 80

this may help i install this in virtual box and had nextcloud up and running in 40 mins its a pre config script with minimual in put has lets encrypt and file to ban security

you can visit for other images but i found it very easy after trying for weeks to setup nextcloud

yes, freenas runs on port 80 and 443. but how to change port of nextcloud or how to check on which port the nextcloud is running?/

I am assuming you are running your NC instance on a server PC that is independent of the FreeNAS installation?
If not read the documentation for NC and your server OS or Freenas on how to assign ports other than 80 / 443.

So have you created a Ngrok tunnel on your nextcloud server? If so have you read and understood the Ngrok documentation? see the section on ’ Forwarding to servers on a different machine (non-local services)’

What dose going to get you or goto
or reach out and ask for control