Calendar item updates are very slow

Hi,

I use Nextcoud 24 with calendar. Everything is fine.

I use CalDAV to import the calendar items in Thunderbird. When I open Thunderbird, the synchronicing works, I get the alerts. But when I update an item, it takes 5~10 secondes to update the item. This is too slow. How can I speedup this point?

Thank you.

1 Like

Hi,

I had the same problem.
The solutions exposed here fixed it for my user : Several issues after upgrading to Nextcloud 21 - #3 by fabsta

Kind regards,
Thierry

I have updated Nextcloud but still facing the same problem. Things are very slow now.

Any other possible solutions?

Hi, I have also the same issue with Nextcloud 24.0.4. and Calendar 3.4.2. I don’t know whether this might be Thunderbird related. I am using different versions (91.11.0 (64-bit) to 102.1.2 (64-bit)).
I also don’t know if the protocol (CalDAV) doesn’t allow for a high amount of calendar entries. Is there a best practice, like e.g. changing your calendar every year?
Best regards

I can’t really explain why, but I found a solution for me (also thanks to another post here).

What worked for me is the following:

  1. Like in the linked post described, I tried to set an App Password for Thunderbird alone.
  2. What I noticed was, that there were hundreds of entries in the list (beginning from 4 months ago or so).
  3. I set a App Password for Thunderbird and subscribed my calendar in Thunderbird again.
  4. The first test showed no improvement of speed.
  5. After revoking all the devices that were duplicates most of the time, I tested to add a new entry again and after only 1-2 seconds the entry was shown. Also deletion was almost instant (compared to the 5-10 seconds before).

PS: You find App Passwords under “Settings → Security”. You might have to scroll down a bit (like me).

I hope I could help someone with this. What the reason is - no clue. Might be related to this database-problem mentioned in the other linked problem/solution of @pielonet.

Cheers