Calendar issues since upgrade to 11

Yesterday I updated from 10.0.2 to 11 (manual update). Everything went very smoothly. There have only been two minor issues (one of which is already reported so skipping that here). I have been poking at the second issue for over an hour and I am just not making progress.

Local PC Setup:
Ubuntu 16.04
Thunderbird 45.5.1
Lightning 4.7.4

What happened.
I sync my calendars to Thunderbird email client with the Lightning plugin. I’ve been doing that for a while. Right after the upgrade, NONE of the calendars would sync. I went debugging and found that Thunderbird was getting URL rejections. This:
turned to this:

“Well, that’s weird. I wonder why they changed caldav to just dav…whatever.”

And I went about fixing it. Most of my titles still referenced OC, so time to rename it all anyway. I unsubscribed all my calendars and copied the URL from the NC link just to ensure I had the right ones. Bingo! All my calendars were syncing again. Hooray!

I have a meeting coming up, I added the event and invited the person that needed to be there before going on my way. Fortunately, I saw him before our meeting “Did you get my invite?”
“Uhhh…I sent it.”
“Nope. See? Nothing from you.”

Sure enough, Thunderbird/NC sees the event and it synced to all my devices, but it didn’t send the email! I always have something in my sent outbox. This is the first time it has ever happened that it didn’t send!

What I’ve done to debug the problem.

  1. Verified event and invite. Event->Attendees->Correct people are listed. However “Notify Attendees” is checked, but greyed out.
  2. Verified there was an email associated with the calendar. Calendar Tab->Default NC Calendar->Properties->E-mail. That is correct.
  3. Verified it is just this calendar. Attaching to my work calendar I can invite someone and I see that the “Notify Attendees” can be checked or unchecked.
  4. Verified it isn’t just the default calendar. I created a new NC calendar, synced it to Thunderbird, created a new event, & ensured it synced. Then I modified and tried to invite someone. Same greyed out field for “Notify attendees.”

I found this link which I think might be related, but I haven’t tried it yet. Thoughts?


Well, I am not finding the information listed in that link in the NC code base. Thoughts?

About the changes URL: I had a similar experience but could not (yet) verify if it was caused by the changes URL.
IF it is, I’d suggest to line out such changes more visible in the changelog in future version, this is BREAKING stuff and potentionally annoying users :frowning:

@stack, did you try to work around it with a Rewrite rule?

This feature needs to be supported by the server which is currently not the case. Related topics on the bugtracker to follow the development:

I don’t know why this was marked as a solution. This isn’t fixed yet and it is extremely annoying. I’ve tried a number of things and even hacked on the code trying to revert all of the changes made but never got it to work.

This feature is not supported in the current version. New features and bugs are handled on github. So any questions regarding the implementation and following the progress should be done on github, there is nothing we can do about in the forum. If you want you can put a bounty on this bug as a motivation for a developer:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.